Take the 2-minute tour ×
Network Engineering Stack Exchange is a question and answer site for network engineers. It's 100% free, no registration required.

Im having an issue with an AIR-AP1252ag that wont advertise multiple SSIDs in Beacons. Im trying to setup 3 SSIDs, 1 hidden (Controls), 1 Guest (works fine), 1 Internal Data-Wifi The problem is that the Internal Data WLAN is not sending the SSID in the beacons. To a end host/client, It just shows up like a hidden network. Im using c1250-k9w7-tar.152-2.JA.tar for the image. And im starting to think from reading the config guide that i should just go back to 12.4 But i wanted to ask the question to see if anyone can help me set this up right first. It 'Should' be fairly simple & im probably missing something silly. Below is the config. I've tried a mix of information-element ssidl advertisement with & without mbssid under the dot11 ssid But i just cant figure out the right combination to get the ssid advertised properly.

!
dot11 syslog
!
dot11 ssid Controls
   vlan 32
   authentication open
   authentication key-management wpa version 2
   mbssid dtim-period 50
   wpa-psk ascii 7 xxxxxxxxxxxxxxx
!
dot11 ssid Guest
   vlan 31
   authentication open
   mbssid guest-mode dtim-period 75
   information-element ssidl advertisement
!
dot11 ssid Data-Wifi
   vlan 30
   authentication open
   authentication key-management wpa version 2
   mbssid dtim-period 75
   wpa-psk ascii 7 xxxxxxxxxxxxxxxxxx
   information-element ssidl advertisement
!
crypto pki token default removal timeout 0
!
!
username admin privilege 15 secret xxxxxxxxxxxxxxxxxxxxx
!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 30 mode ciphers aes-ccm tkip
 !
 encryption vlan 32 mode ciphers aes-ccm tkip
 !
 ssid Controls
 !
 ssid Guest
 !
 ssid Data-Wifi
 !
 antenna gain 0
 mbssid
 station-role root access-point
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.30
 encapsulation dot1Q 30
 no ip route-cache
!
interface Dot11Radio0.31
 encapsulation dot1Q 31
 no ip route-cache
!
interface Dot11Radio0.32
 encapsulation dot1Q 32
 no ip route-cache
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 antenna gain 0
 dfs band 3 block
 channel dfs
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!
interface GigabitEthernet0.30
 encapsulation dot1Q 30
 no ip route-cache
!
interface GigabitEthernet0.31
 encapsulation dot1Q 31
 no ip route-cache
!
interface GigabitEthernet0.32
 encapsulation dot1Q 32
 no ip route-cache
!
interface BVI1
 ip address 172.16.99.15 255.255.255.0
 no ip route-cache
!
bridge 1 route ip
bridge 1 protocol ieee
share|improve this question

1 Answer 1

up vote 5 down vote accepted

Data-Wifi doesn't have guest-mode enabled (mbssid guest-mode) so it will not beacon.

See Also: guest-mode and mbssid guest-mode

share|improve this answer
    
Thanks so much, that did it. –  LucentMoon Sep 4 at 12:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.