Take the 2-minute tour ×
Network Engineering Stack Exchange is a question and answer site for network engineers. It's 100% free, no registration required.

We are trying to replace our existing router with a newly purchased CISCO router:

GigabitEthernet0/0: PPPOE GigabitEthernet0/1: 192.168.2.1

The PPPOE is getting established perfectly, and I can ping the outside from inside CLI however, the clients cannot ping the outside world. As mentioned, this is replace an existing router with the same ip (ie, 192.168.2.1) therefore, the clients are all setup and working fine when not using the CISCO router. My config bellow:

    Current configuration : 2698 bytes
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r1
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 <secret>
!
aaa new-model
!
aaa session-id common
!
dot11 syslog
ip source-route
!
ip cef
!
ip domain name test.com
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
!
crypto pki token default removal timeout 0
!
license udi pid CISCO3825 sn FTX1039A0AA
username admin privilege 15 secret 4 <secret>
!
redundancy
!
interface GigabitEthernet0/0
 no ip address
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
 media-type rj45
 pppoe enable group global
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface GigabitEthernet0/1
 ip address 192.168.2.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 media-type rj45
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip proxy-arp
 ip mtu 1492
 ip flow ingress
 encapsulation ppp
 ip route-cache policy
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username <username> password 0 <password>
 ppp ipcp dns request accept
 ppp ipcp route default
 ppp ipcp address accept
 no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat pool voip-rtp 192.168.2.5 192.168.2.5 netmask 255.255.255.0 type rotary
ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip nat inside source static tcp 192.168.2.10 25 77.71.31.187 25 extendable
ip nat inside source static tcp 192.168.2.5 53 77.71.31.187 53 extendable
ip nat inside source static tcp 192.168.2.15 80 77.71.31.187 80 extendable
ip nat inside source static tcp 192.168.2.15 443 77.71.31.187 443 extendable
ip nat inside source static tcp 192.168.2.10 465 77.71.31.187 465 extendable
ip nat inside source static tcp 192.168.2.10 993 77.71.31.187 993 extendable
ip nat inside source static tcp 192.168.2.10 995 77.71.31.187 995 extendable
ip nat inside source static udp 192.168.2.5 5060 77.71.31.187 5060 extendable
ip nat inside source static udp 192.168.2.20 5080 77.71.31.187 5080 extendable
ip nat inside destination list 114 pool voip-rtp
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
ip route 64.230.11.5 255.255.255.255 GigabitEthernet0/0
!
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 114 permit udp any any range 8000 65535
!
control-plane
!
mgcp profile default
!
line con 0
line aux 0
line vty 0 4
 transport input ssh
!
scheduler allocate 20000 1000
end 

Things I tried:

Statically setting the IP route: ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 ip route 64.230.11.5 255.255.255.255 GigabitEthernet0/0 Although this is probably not needed for auto established PPPOE connection?

Update

IP NAT Trans Output

Pro Inside global         Inside local          Outside local         Outside global
tcp 77.71.31.187:53       192.168.2.5:53        ---                   ---
udp 77.71.31.187:5060     192.168.2.5:5060      <voip supplier's ip>:5060   <voip supplier's ip>:5060
udp 77.71.31.187:5060     192.168.2.5:5060      <voip supplier's ip>:5060   <voip supplier's ip>:5060
udp 77.71.31.187:5060     192.168.2.5:5060      ---                   ---
tcp 77.71.31.187:25       192.168.2.10:25       217.160.226.122:25    217.160.226.122:25
tcp 77.71.31.187:25       192.168.2.10:25       ---                   ---
tcp 77.71.31.187:465      192.168.2.10:465      ---                   ---
tcp 77.71.31.187:993      192.168.2.10:993      ---                   ---
tcp 77.71.31.187:995      192.168.2.10:995      ---                   ---
tcp 77.71.31.187:80       192.168.2.15:80       66.249.74.2:33795     66.249.74.2:33795
tcp 77.71.31.187:80       192.168.2.15:80       66.249.74.2:50496     66.249.74.2:50496
tcp 77.71.31.187:80       192.168.2.15:80       ---                   ---
tcp 77.71.31.187:443      192.168.2.15:443      ---                   ---
udp 77.71.31.187:5080     192.168.2.20:5080     ---                   ---
share|improve this question
1  
How are the clients getting IP addresses? Static or via DHCP (from the existing router)? –  Ron Dec 30 '13 at 19:30
    
Hey Ron! Thank your for your response. I should have mentioned, all addresses are statically defined. This is why I did not implement dhcp on the cisco unit. –  Nick Cameo Dec 30 '13 at 19:45
    
Next question: I am assuming there is a switch between the router and the clients. Have you tried clearing the ARP cache on the clients? –  Ron Dec 30 '13 at 19:51
    
Ron, I really appreciate you trying to debug my network. Yes there is a switch, it's a foundry FESX448. Ummm ARP? I will attempt to plug a client directly into the router and see if the results differ. –  Nick Cameo Dec 30 '13 at 19:52
    
When the client sends a packet to the default gateway (router), it sends the packet to the router's MAC address. If there is a switch between the client and the router, then the client will think the routers MAC is still the old one. Try clearing the arp cache. On Windows, it's arp -d * –  Ron Dec 30 '13 at 19:57
show 7 more comments

2 Answers

up vote 5 down vote accepted

NAT is applied to g0/0, not di0 where it is required. (there's no IP running on g0/0, so none of the IP configuration matters there.)

int di0
 ip nat outside
!
no ip nat inside source list 1 interface GigabitEthernet0/1 overload
ip nat inside source list 1 interface di0 overload

The two route statements are not necessary. If you need something to trigger the dialer, the route would be ip route 0.0.0.0 0.0.0.0 dialer0, but it should be triggered as long as g0/0 is up/up.

share|improve this answer
add comment

The NAT statement

ip nat inside source list 1 interface GigabitEthernet0/1 overload

is incorrect. You should specify the dialer0 interface instead. Here's a helpful link.

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/pppoenat.html#wp1235296

share|improve this answer
    
I will change the statement to ip nat inside source list 1 interface Dialer0 overload. Also, is the ip route statement needed? I am hard coding the gateway however, would like it to be determined by dialer0 when the connection is established –  Nick Cameo Dec 30 '13 at 21:44
    
Also move the ip nat outside statement to the dialer, as Ricky mentioned. –  Ron Dec 30 '13 at 21:46
    
This all works now. SIP UDP works however, my RTP UDP range is not working. I read this would be an issue. If a 50 dollar dlink can do it why? oh why? –  Nick Cameo Dec 30 '13 at 22:15
    
The following is what I have for RTP port forwarding for voip however, to be honest, I am not sure if it is actually correct: ip nat pool voip-rtp 192.168.2.5 192.168.2.5 netmask 255.255.255.0 type rotary ip nat inside destination list 114 pool voip-rtp access-list 114 permit udp any any range 8000 65535 –  Nick Cameo Dec 30 '13 at 23:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.