Take the 2-minute tour ×
Network Engineering Stack Exchange is a question and answer site for network engineers. It's 100% free, no registration required.

My current setup is as follows:

Cisco 881 router (only 1 WAN interface) that has a pair of T1's coming in on the WAN interface, this currently provides internet access to two VLANs, 10 and 20.

What is changing:

We are adding another pair of T1's, for a total of two Internet connections.

My thoughts on a solution:

The end goal is to have one pair of T1's be dedicated to VLAN 10 and the other pair to VLAN 20. My thought right now is to add another router that connects to the 881 router that acts as a gateway for the second T1 pair. So I'd have VLAN 10 route to the Internet via the 881 router, and VLAN 20 via a new router that connects to the second pair of T1's. Is this the best setup or would you go about it a different way?

share|improve this question
    
Why do you need to have each VLAN use a separate T1 to the Internet? Is there a specific reason? If not, it would be better (faster, more reliable) to share the two connections with both VLANs. –  Ron Jan 6 at 18:03
    
Are you willing to buy a 2nd router and run GLBP? That way you can use both ISPs –  user3809 Jan 8 at 0:20

2 Answers 2

up vote 8 down vote accepted

Assuming you have the correct IOS and feature set (IOS >=15.0(1)M7 & Adv IP Services license loaded), the simplest way to do this is by putting each internet link and Vlan in a different VRF (this is a VRF-lite config). Assume you want to use:

  • Ethernet1/0 uplink for Vlan10
  • Ethernet2/0 uplink for Vlan20

The configuration would look similar to this...

ip vrf Inet_Vlan10
 rd 65535:10
 route-target 65535:10
!
ip vrf Inet_Vlan20
 rd 65535:20
 route-target 65535:20
!
interface Ethernet1/0
 ip vrf forwarding Inet_Vlan10
 ip address 192.0.2.2 255.255.255.252
 ! insert nat, if required
interface Ethernet2/0
 ip vrf forwarding Inet_Vlan20
 ip address 192.0.2.6 255.255.255.252
  ! insert nat, if required
interface Vlan10
 ! This assumes you're using the onboard switch in a C800 series
 ip vrf forwarding Inet_Vlan10
 ip address 10.0.1.254 255.255.255.0
 ! insert nat, if required
interface Vlan20
 ! This assumes you're using the onboard switch in a C800 series
 ip vrf forwarding Inet_Vlan20
 ip address 10.0.2.254 255.255.255.0
 ! insert nat, if required
! Simple example of routing Vlan10 out Ethernet1/0
ip route vrf Inet_Vlan10 0.0.0.0 0.0.0.0 <ip_addr_in_192.0.2.0/30>
! Simple example of routing Vlan20 out Ethernet2/0
ip route vrf Inet_Vlan20 0.0.0.0 0.0.0.0 <ip_addr_in_192.0.2.4/30>

VRFs dedicate a different forwarding table for each VRF; thus you can have dedicate an internet access provider for each Vlan, exactly as you described in your question.

share|improve this answer
    
there's only one routed port on the 881 that can take ip address, right ? –  aseaudi Jan 6 at 18:29
    
Hi aseaudi, I guess youre new and unfamiliar with how we answer... welcome to Stack Exchange. We dont know how his uplinks are configured and we dont know his addressing, so it is common on Stack Exchange to provide generic configs. Subinterfaces, svi, etc provide plenty of ways to handle this; it's trivial to substitute interface names and ip addresses. –  Mike Pennington Jan 6 at 18:37

For fixed configuration and not modular chassis (i.e. cannot add another WAN to the same chassis), then you need 2 routers for 2 WANs.

However, I know that the 881 has a 10/100 Mbps FastEthernet WAN Interface, not T1, right ?

This means if the WAN is Ethernet Acces, then you can have more than one WAN on the same chassis.

1st WAN Ethernet can be connected to the chassis WAN Interface.

And 2nd WAN Ethernet can be connected to one of the 4 ports of the integrated switch, you will need to configure a vlan with ip address in order for the switch port to accept the 2nd WAN, and you will lose QoS for the 2nd WAN.

But I still prefer 2 fixed config routers for 2 WANs.

share|improve this answer
    
Hey Aseaudi, thanks for your response. You're right that the T1 doesn't connect directly to our 881, but is terminated before hand and we just get an Ethernet hand-off from the ISP. So to make sure I understand, I'll dedicate an interface on the 881's integrated switch, and set an IP address on that interface which will be the new default gateway for that network? –  David Rediger Jan 6 at 18:05
    
If you do not want to buy a 2nd router, then Yes. But, you cannot configure ip directly on the switch port, you need to create vlan first and then assign ip address on the vlan, because the ports on the switch are layer 2 ports, not routed ports, and you will lose QoS for this 2nd WAN. –  aseaudi Jan 6 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.