Network Engineering Stack Exchange is a question and answer site for network engineers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently came across an issue while setting up a stack to replace an older M switch setup. I stacked 3 switches - 2 Cisco 2960's and 1 C2960 PoE using SFP cables to their backplane.

My plan was to use the SFP modules on the front end of the switches to uplink straight to the core rather than to a bottom M and a Top M that were uplinked to Core1 and Core2.

We purchased non-cisco SFP's (Cisco's are much more expensive) and installed them. What I noticed via Termmon, was that each SFP was going down as soon as it was plugged in.

000016: *Feb 28 22:35:32.507 EST: %PHY-4-SFP_NOT_SUPPORTED: The SFP in Gi2/0/50 
 is not supported (B2-FL1-Stack-2)
000017: *Feb 28 22:35:32.507 EST: %PM-4-ERR_DISABLE: gbic-invalid error detected
 on Gi2/0/50, putting Gi2/0/50 in err-disable state (B2-FL1-Stack-2)

It's outputting that they are not compatible which is confusing considering the SFP is an international standard.

share|improve this question
This is not a recommended config, but some people "get away" with doing this. In config mode, try service internal and service unsupported-transceiver. Now shut / unshut ports, and remove / reinsert the transceivers. Note: you're rolling the dice, because 3rd-party SFPs are not as easy to do this with as the old GBICs transceivers were. – Mike Pennington Mar 21 '14 at 14:48
up vote 11 down vote accepted

After some research I determined that Cisco automatically disables non cisco branded SFPs. In order to prevent them from defaulting to err-disable I had to enter the following commands in config mode.

Router(config)#service internal
Router(config)#no errdisable detect cause gbic-invalid
Router(config)#service unsupported-transceiver

I then configured the SFP interface to a management vlan, connected a laptop to it by changing the laptop's IP address and confirmed that the SFP does indeed take traffic. Hope this helps!

share|improve this answer
For those of you still having a problem, consider upgrading to IOS 15.0.2, there is a bug in 15.0.1 that doesn't allow non-cisco SFPs to function. – HAL Jun 3 '15 at 19:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.