Network Engineering Stack Exchange is a question and answer site for network engineers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a cisco 1941 router just configured but no matter how I go about configuring the telnet, it seems not to work.

It has interfaces already set up and systems can browse through it in the office. It has two interfaces WAN and LAN configured with Ip Addresses and the LAN interface with other sub interfaces with IP address configured on them.

I have tried setting up the terminal with the command as stated below but it is not working.

Router(config)#line vty 0 ?
<1-1370> Last Line Number
Router(config-line)#line vty 0 1370
Router(config-line)# password P@$$W)RD
Router(config-line)# login

I even tried using the following configuration but yet not working

Router(config)#line vty 0 4
Router(config-line)# password P@$$W)RD
Router(config-line)# login

Everytime I try to connect to the any of the subinterfaces through telnet or the WAN address through telnet, I get the error message

MacBook-Pro:~ User$ telnet x.x.x.x
Trying x.x.x.x...
telnet: connect to address x.x.x.1x Connection refused
telnet: Unable to connect to remote host

Please what am I getting wrong here?

share|improve this question
Are you in the same LAN of the router? – radtrentasei Apr 3 '14 at 8:51
Yes... on the same Lan. The system I am connecting from is connected to the subinterface of the Lan. Interface GigabitEthernet 0/1.1 – Olanrewaju T Apr 3 '14 at 9:01
If you are using subinterfaces I guess you are using VLANs, is the switch properly configured? If you prefer we can switch this conversation on the chat – radtrentasei Apr 3 '14 at 9:05
@OlanrewajuT Do you have any ACLs setup on the Router? – Ryan Foley Apr 3 '14 at 9:42
Yes... I have ACLs on the router and are configured correctly. – Olanrewaju T Apr 3 '14 at 10:25
up vote 6 down vote accepted

The issue has been resolved. When I checked the running configuration on the router, I noticed I have the line below under the line vty 0 4

access-list class 23 in

All I had to do was to negate the command and everything went back to normal.

Thanks all for your support.

share|improve this answer
If this router is sitting on the Internet edge, are you sure you want to negate your ACL that gave some additional protection to you? Perhaps updating access-list 23 is more appropriate. – generalnetworkerror Aug 11 '14 at 8:00
How do you mean? Please explain! The access list has no function on the router. – Olanrewaju T Apr 23 '15 at 12:34
@OlanrewajuT, the access-list class 23 in on a VTY applies an ACL limiting access to the VTY's. It is best practice to use them to limit management access to the device. – YLearn Jul 17 '15 at 19:03

-- at the running configuration in the line vty interface check if the transport input is set... if it says tansport input none, then go to the line vty interface and write the following command transport input telnet.

share|improve this answer

run this command in your router

conf t
line vty 0 4
transport input all
share|improve this answer
You could improve your answer by editing it to add more details to make it more useful both for the original poster and future users. Typically short answers like this could provide reasoning why you believe this is the answer, more explanation about the concepts mentioned, references/links to supporting resources, or applicable examples. – YLearn Sep 4 '15 at 5:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.