0

I have been working on the setup below and basically I can't have OSPF populate the Routing tables of the L3 switches. I have properly set up L3 Etherchannels between them with the proper addressing. I have attached a few screenshots for further analysis.

The only route advertised by OSPF is a default route that I didn't set up. I manually set up the router ID's for each router and simply created an OSPF process and assigned the area 0 to them all.

IP routing has been enabled on the L3 switches too.

Thanks in advance

enter image description here

R1:

Current configuration : 1718 bytes
!
version 12.2(37)SE1
!
hostname R1
!
ip routing
!
spanning-tree mode pvst
!
interface Port-channel1
 no switchport
 ip address 1.1.1.1 255.255.255.0
!
interface Port-channel3
 no switchport
 ip address 3.3.3.1 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 no ip address
 channel-group 1
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/2
 no switchport
 no ip address
 channel-group 1
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/5
 no switchport
 no ip address
 channel-group 3
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/6
 no switchport
 no ip address
 channel-group 3
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
!
end
 

R2:

Current configuration : 1718 bytes
!
version 12.2(37)SE1
!
hostname R2
!
ip routing
!
spanning-tree mode pvst
!
interface Port-channel1
 no switchport
 ip address 1.1.1.2 255.255.255.0
!
interface Port-channel2
 no switchport
 ip address 2.2.2.1 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 no ip address
 channel-group 1
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/2
 no switchport
 no ip address
 channel-group 1
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/3
 no switchport
 no ip address
 channel-group 2
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/4
 no switchport
 no ip address
 channel-group 2
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
ip classless
!
ip flow-export version 9
!
end
 

R3:

Current configuration : 1718 bytes
!
version 12.2(37)SE1
!
hostname R3
!
ip routing
!
spanning-tree mode pvst
!
interface Port-channel2
 no switchport
 ip address 2.2.2.2 255.255.255.0
!
interface Port-channel3
 no switchport
 ip address 3.3.3.2 255.255.255.0
!
interface FastEthernet0/3
 no switchport
 no ip address
 channel-group 2
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/4
 no switchport
 no ip address
 channel-group 2
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/5
 no switchport
 no ip address
 channel-group 3
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/6
 no switchport
 no ip address
 channel-group 3
 ip ospf 10 area 0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
!
ip classless
!
ip flow-export version 9
!
end
6
  • 1
    Please, never use an image for text. Simply copy the text and paste it into the question using the Preformatted-text option ([]).
    – Ron Maupin
    Jun 25, 2020 at 20:23
  • Also, we need to see the full network device configurations. We cannot simply guess where you may have gone wrong.
    – Ron Maupin
    Jun 25, 2020 at 20:24
  • Are you missing some network 192.0.2.0 0.0.0.255 area 0 statements to make your link-nets part of an OSPF area? Please update your post with more of your device configurations. Jun 25, 2020 at 22:14
  • There's no functional difference to OSPF between a single physical link and an "L3 Etherchannel". Any topology you build with one can be built with the other. Build your topology with standard Ethernet links and then convert those links to port-channels (...you can even reuse the same IP's).
    – rnxrx
    Jun 26, 2020 at 1:58
  • Thanks for all your comments. Still working on the issue, though. I have updated the post and now it includes the settings for all the routers. Much appreciated the effort. Jun 26, 2020 at 13:45

2 Answers 2

2

You have not configured OSPF properly.

You need to add network statements to define which interfaces participate in OSPF and which areas they are in. The easiest way to do that is to include all interfaces in area 0. Add this command to your OSPF configuration:

 router ospf 10
 network 0.0.0.0 255.255.255.255 area 0
7
  • If I use the command ip ospf 10 area 0 on the interfaces I want OSPF to be enabled, wouldn't it be equivalent to issuing the network command? Thanks for the input. Jun 26, 2020 at 14:53
  • You are not running OSPFv3, so you need network statements.
    – Ron Maupin
    Jun 26, 2020 at 15:01
  • Thank you very much. The network command fixed the issue and the OSPFv3 requirement I was not aware of!! Jun 26, 2020 at 15:19
  • @JoãoVictor, you could run OSPFv3, which is required to use IPv6, but optional for IPv4. Then you can put a lot of the configurations on the interfaces, and you would use address families under the OSPFv3 router command for IPv4- or IPv6-specific information.
    – Ron Maupin
    Jun 26, 2020 at 15:49
  • Is there any way to quickly find out which OSPF version is running on the L3 switch/router? Jun 26, 2020 at 16:06
1

A router protocol will only advertise routes:

  • received from other routers via this routing protocol
  • redistributed from other routing tables, including connected and static, when this redistribution is configured, for example if there's a redistribute connected in your configuration
  • manually configured, typically in OSPF with a network statement, provide the route exists in the forwarding table

Additionally for OSPF, you must configure which interface participate in the OSPF process, with a "network" statement.

For example:

  • you have 2 interfaces with IP address 192.168.0.1/24 and 192.168.1.1/24
  • if you add in your OSPF configuration network 192.168.0.0/24 then only the first interface will be used by the process.
  • if you add network 192.168.0.0/23 instead, both interface will be able to establish relationship.
1
  • Thank you for the clarification. I have updated the post with all the devices settings. Appreciated the further analysis. Jun 26, 2020 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.