We have a VMWare ESXi host with a single network port. It's connected to a Cisco Catalyst 3750 switch port and the configuration of thew switch port is as follows:
interface FastEthernet 1/0/2
switchport access vlan 10
switchport mode access
end
We need to run a guest on a separate vlan (vlan 11 and 12) and so we change the switch configuration as follows:
interface FastEthernet 1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan add 10,11,12
end
When this is done we lose access to the host. What is wrong with this configuration?