1

I'm using Cisco Packet Tracer, computers on the same network can contact easily with each other, but when I send message from a network computer to the other, i get a FAILED message.

Configuration file is attached and this image illustrates my situation, can I get some help with that please?

enter image description here

Download Tracer File

Gateway for network PCs on the left (0, 2, 1)

10.1.4.1

Gateway for network PCs on the right (3, 4)

10.1.3.0

Router A CLI:

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#router rip
Router(config-router)#
Router(config-router)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 10.1.4.1 255.0.0.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Router(config-if)#exit
Router(config)#router rip
Router(config-router)#no network 10.0.0.0
Router(config-router)#no network 172.20.0.0
Router(config-router)#network 172.20.0.0
Router(config-router)#network 10.0.0.0
Router(config-router)#no network 10.0.0.0
Router(config-router)#
Router(config-router)#exit
Router(config)#ip route 172.21.0.0 255.255.0.0 10.1.4.1
%Invalid next hop address (it's this router)
Router(config)#ip route 172.21.0.0 255.255.0.0 10.1.4.1
%Invalid next hop address (it's this router)
Router(config)#ip route 172.21.0.0 255.255.0.0 10.1.4.1
%Invalid next hop address (it's this router)
Router(config)#
Router(config)#interface FastEthernet0/0
Router(config-if)#no ip address
Router(config-if)#








Router con0 is now available






Press RETURN to get started.












%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up


Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#no network 10.0.0.0
Router(config-router)#
Router(config-router)#exit
Router(config)#ip route 172.21.0.0 255.255.0.0 10.1.4.1
Router(config)#ip route 172.10.0.0 255.255.0.0 10.1.4.1
Router(config)#ip route 172.23.0.0 255.255.0.0 10.1.8.2
Router(config)#








Router con0 is now available






Press RETURN to get started.













Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 10.1.4.1 255.0.0.0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#








Router con0 is now available






Press RETURN to get started.













Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#

Router B CLI:

Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#
Router(config-router)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#router rip
Router(config-router)#network 10.0.0.0
Router(config-router)#
Router(config-router)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 172.21.0.1 255.0.0.0
Router(config-if)#no ip address
Router(config-if)#ip address 172.21.0.1 255.255.0.0
Router(config-if)#
Router(config-if)#exit
Router(config)#
Router(config)#router rip
Router(config-router)#








Router con0 is now available






Press RETURN to get started.













Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#no ip address
Router(config-if)#shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/1
Router(config-if)#ip address 172.21.0.1 255.255.0.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/1
Router(config-if)#no ip address
Router(config-if)#
Router(config-if)#exit
Router(config)#interface Serial0/0/0
Router(config-if)#ip address 172.21.0.1 255.255.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config-if)#exit
Router(config)#router rip
Router(config-router)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
network 172.10.0.0
Router(config-router)#no network 172.21.0.0
Router(config-router)#no network 172.10.0.0
Router(config-router)#no network 10.0.0.0
Router(config-router)#network 172.21.0.0
Router(config-router)#








Router con0 is now available






Press RETURN to get started.












%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up


Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#end
Router#erase startup-config
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
%SYS-5-CONFIG_I: Configured from console by console
N
Router#
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/0/0
Router(config-if)#
Router(config-if)#end
Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#
Router(config-if)#exit
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 10.1.3.0 255.0.0.0
Router(config-if)#








Router con0 is now available






Press RETURN to get started.













Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0
Router(config-if)#

show ip route output for each router:

Router B

    Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0
C 172.21.0.0/16 is directly connected, Serial0/0/0

Router A

    Router#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0
C 172.20.0.0/16 is directly connected, Serial0/0/0
12
  • Most of us don't use packet tracer. Can you edit your post to include the router configurations (use the preformatted text option)
    – Ron Trunk
    Commented Jan 7, 2018 at 13:31
  • As a first guess according to your diagram, your serial interfaces are not on the same network.
    – Ron Trunk
    Commented Jan 7, 2018 at 13:33
  • Can the routers ping each other? What default gateways do the PCs have?
    – Zac67
    Commented Jan 7, 2018 at 13:37
  • I edited the question with more information.
    – tinyCoder
    Commented Jan 7, 2018 at 13:52
  • Looks like you don't have correct IP addreses. Post the output of "show ip route" for each router.
    – Ron Trunk
    Commented Jan 7, 2018 at 13:57

3 Answers 3

2

The serial ports are configured incorrectly. You can configure them within 172.21.0.0/16 but each side must have an IP address in that subnet.

When RIP is active an the serial interfaces the routes should get across. Without RIP, each router requires a route to the other side's PC subnet through the opposite router's serial port. You can't use the PC-facing IP address.

2

Finally got my hands on PT version 7.

Yes indeed as pointed out by @Zac67 check the serial ports.

From the file you shared and after changing serial ports IP subnet it will still not work. If you check both routers none display the letter 'R' for RIP routes in "show ip route", yet when you run "show ip protocols" it does say RIP is advertising for both subnets, it is even reflected when running the debug.

If you check both routing tables, both see 10.0.0.0/8 directly connected. For some reason RIP is not liking this fact when updating the route sent from the other peer.

Split Horizon seems to be the key because they are both advertising the same subnet 10.0.0.0/8, and as you know, this would create a loop unless a loop prevention mechanism takes place.

Anyways I changed the subnet from the other set of PC's to 192.168.4.0 , added RIP as version 2 and it worked.

The following link you can download the modified version of the lab.

1

As @zac67 points out, your serial interfaces are wrong. They need to be in the same subnet (you can test this by trying to ping the serial interface of one router from the other). You are using network addresses (the first IP in the subnet) instead of host addresses.

You should be able to remove all your static routes if you have configured RIP.

3
  • Thank you both Ron, as i'm totally new to the network experience and trying to figure out what are you asking me to do exactly, I couldn't understand how to solve it, you told me the problem but I don't know how to apply the solution yet.. I will keep trying and be back.
    – tinyCoder
    Commented Jan 7, 2018 at 18:23
  • For example, use 172.21.0.1/16 and 172.21.0.2/16 for the serial interfaces.
    – Ron Trunk
    Commented Jan 8, 2018 at 0:08
  • Also, you have the same network 10.0.0.0/8 on each router. That is a improper design. Each network needs to be unique.
    – Ron Trunk
    Commented Jan 8, 2018 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.