5

I am trying to setup a network that includes an EtherChannel link between two Cisco Layer 3 switches (Catalyst 3750). I am using a collapsed core hierarchical network.

collapsed core topology

The picture above is my topology. On my layer 2 access switches (S1, S2, S3) I have several hosts connected right now, on several VLANs. My issue tho is that a host on for example S2, can't communicate with L3-1 through the EtherChannel between L3-1 and L3-2. I've tried making it a Layer 3 EtherChannel with IP's, and I can ping across, but it's like it wont propagate my tagged VLAN traffic.

Example:

I connect HOST-A to L3-1 on interface GigabitEthernet2/0/1.

I make GigabitEthernet2/0/1 switchport access on VLAN 20.

HOST-B is connected to a switchport access VLAN 20 port on S2.

HOST-B tries to ping L3-2. Succesful.

HOST-B tries to ping across to L3-1 / HOST-A. Not succesful.

PS. I also have HSRP setup on the Layer 3 switches, for all my VLANs. Also I have a Main Windows Server 2016 Domain Controller connected to L3-1 and a Backup connected to L3-2.

Let me know if you need the IP scope.

I appreciate all help! I just want to know what I have to think of/be sure of is working, to make this network communicate. Any help that can guide me to what i can do to get traffic all the way to the WAN, and so that my hosts on S1, S2 and S3 can connect to the internet. Much appreciated.

CONFIGURATION:

L3-1

Port-Channel:

!
interface Port-channel1
 no switchport
 ip address 172.16.0.1 255.255.255.252
!
!
interface GigabitEthernet2/0/19
 no switchport
 no ip address
 channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
 no switchport
 no ip address
 channel-group 1 mode desirable
!

L3-2 has same configuration on same ports and channel-group. It's IP address is 172.16.0.2 255.255.255.252 instead.

VLAN-config: show vlan brief in cisco terminal

All links between layer-3 and layer-2 switches are trunks. A snippet from L3-2: interface overview from layer 3 switch

S1

VLAN-config: vlan overview on switch

S2

VLAN-config: vlan overview on switch

S3

VLAN-config: vlan overview on switch

6
  • you need to add the configuration of the devices. Also the result of the show vlancommand on S1, S2 & L3-1 along with the name of the interfaces that connect those switches together would be useful.
    – JFL
    Commented Jan 25, 2018 at 8:40
  • Definitely need configurations to give any help. Remember to sanitize the configuration files and remove all passwords etc.
    – user36472
    Commented Jan 25, 2018 at 9:25
  • @Cown I have updated the thread which should highlight your requests. I didn't put in the full configurations for the sake of trying to keep an overview. Do let me know if it's not satisfying enough, tho.
    – Roy T.
    Commented Jan 25, 2018 at 9:41
  • @RoyT. On your links between L3-1 and L3-2, how come you don't use a normal trunked etherchannel? Does the 172.16.0.1 255.255.255.252 have any purpose?
    – user36472
    Commented Jan 25, 2018 at 9:58
  • It will be a lot easier if you would be able to show all the config from the L3-1 and L3-2 plus config from each Access Switch Commented Jan 25, 2018 at 10:00

3 Answers 3

4

@RoyT. On your links between L3-1 and L3-2, how come you don't use a normal trunked etherchannel? Does the 172.16.0.1 255.255.255.252 have any purpose?

For instance, if you put this configuration on the interlink between L3-1 and L3-2:

interface Port-channel1
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet2/0/19
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!
interface GigabitEthernet2/0/20
 switchport
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode desirable
!

Then everything will be able to communicate.

In order to do it:

(config)# int range gi2/0/19-20
(config-if)# no channel-group
(config-if)# switchport
(config-if)# switchport trunk encapsulation dot1q
(config-if)# switchport mode trunk
(config-if)# int po1
(config-if)# no ip address
(config-if)# switchport
(config-if)# switchport trunk encapsulation dot1q
(config-if)# switchport mode trunk
(config-if)# int range gi2/0/19-20
(config-if)# channel-group 1 mode desirable
(config-if)# end
# write memory
4
  • Hi @Cown - I think I already tried this, without success.. I will try again tho, right now I get the error that an interface with encapsulation set to "auto" can't be configured to trunk mode. I will try and set encapsulation 802.1q and try again.
    – Roy T.
    Commented Jan 25, 2018 at 10:44
  • @RoyT. Yeah i used the example on Cisco 6500 series, so no encapsulation needed.
    – user36472
    Commented Jan 25, 2018 at 10:46
  • @RoyT. edited to include encapsulation.
    – user36472
    Commented Jan 25, 2018 at 10:49
  • @RoyT. no problem :-)
    – user36472
    Commented Jan 25, 2018 at 11:52
3

L3 EtherChannel and VLAN/Trunk concepts DO NOT work together.

In this scenario, you should use L2 EtherChannel between L3-1 and L3-2 switches.

Ensure that you create all L3 Int VLANs / L2 VLANs, and trunk them on this L2 EtherChannel between L3-1 and L3-2 switches.

0

Possibly spanning tree is blocking the ports to communicate with each other...

1
  • Spanning tree is a layer-2 protocol. It does not cross a layer-3 boundary. You cannot use layer-2 concepts like VLANs or spanning tree on a layer-3 link. The accepted answer was to change the link to a layer-2 link.
    – Ron Maupin
    Commented Oct 11, 2019 at 2:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.