0

I think I remember reading somewhere that you could have multiple VLANs assigned to a single interface by way of a pseudo interface. Googling with that vocabulary doesn't return proper results though, so I hope I'm just using the wrong words. I have a Cisco WS-C4507R running 12.2(18)EW3 (I know it's old).

I thought the syntax was something like that shown below, but the '.1' isn't making a new interface.

MySwitch#sh run int g4/47
Current configuration : 149 bytes
!
interface GigabitEthernet4/47
 description "The Server's address on VLAN 7"
 switchport access vlan 7
 switchport mode access
 no cdp enable
end

MySwitch#sh run int g4/47.1
Current configuration : 151 bytes
!
interface GigabitEthernet4/47
 description "The Server's address on VLAN 12"
 switchport access vlan 12
 switchport mode access
 no cdp enable
end

Am I misremembering this feature? Is it a thing, but not for my old AF IOS? It appears I can assign two wildly different IPs on a single physical NIC on the client machine, but I would also need to have its switch uplink on the two appropriate VLANs. Am I resigned to making the interface a trunking int and have the two different IPs on the client NIC?

EDIT: Having a client machine with two IPs on a single NIC, that wouldn't create a broadcast loop/storm unless the NIC had bridging or routing configured on it, correct?

5
  • 2
    I think you are talking about a VLAN trunk. There's no other way to make a single NIC part of different VLANs. Of course, you can also simply bind multiple IP addresses to a NIC within a single VLAN.
    – Zac67
    Apr 12, 2019 at 21:44
  • Darn. I was really hoping that pseudo interface was a thing. Yeah I've done that IP aliasing with no problem, but these are two wildly different IP spaces. One's a class A private address, the other is in Class C. I can't change the other device's Class C address to be in the same VLAN either.
    – user208145
    Apr 12, 2019 at 21:52
  • 1
    "One's a class A private address, the other is in Class C." Network classes were deprecated in 1993, and they are not used in modern networking. We use CIDR addressing. You can change the layer-2 interface to a layer-3 interface with the no switchport command, and then assign subinterfaces on the physical interface. Also, many servers can understand VLANs, so you may beble to trunk to the server if you configure it correctly.
    – Ron Maupin
    Apr 12, 2019 at 22:08
  • Thanks. I'm aware of the Class deprecation; I was using that as a descriptor. I will look into the no switchport stuff in a bit.
    – user208145
    Apr 12, 2019 at 23:01
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can provide and accept your own answer.
    – Ron Maupin
    Dec 15, 2019 at 1:40

2 Answers 2

3

You are looking for "sub-interface". The Catalyst 4500 series does not support that feature, but some other Catalysts do (the 6K and I believe some of the newer 9Ks)

1

The feature you are looking for is sub-interface, but as mentioned, most switches do not support this feature. They do support VLAN interfaces, which are similar.

Sub-Interface Example (Router on a stick)

Gi0/0 on this Router would connect to a downstream switch that's configured for a VLAN trunk with VLANs 10, and 20.

interface gi0/0
  description MAIN Physical
  no ip address
interface gi0/0.10
  description DATA VLAN Gateway
  ip address 10.16.10.1 255.255.255.0
  no ip proxy-arp
interface gi0/0.20
  description Voice VLAN Gateway
  ip address 10.16.20.1 255.255.255.0
  no ip proxy-arp

VLAN Interface Example

In this example there would be no additional physical router, the Layer 3 switch would handle the routing.

interface vlan 10
  description DATA VLAN Gateway
  ip address 10.16.10.1 255.255.255.0
  no ip proxy-arp
interface vlan 20 
  description Voice VLAN Gateway
  ip address 10.16.20.1 255.255.255.0
  no ip proxy-arp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.