1

enter image description here

I'm still a beginner with VLANs and trunking, and I'm trying to get this topology working. Specifically, I am unable to ping PC4 (10.0.10.11/32) from PC1 (10.0.10.10/32), despite both of them being on VLAN 10.

I believe I have set up the appropriate switchports with mode access and the trunking ports between Switches 1 and 3, and Switches 2 and 3 respectively. I have not set up IP-addressing on any of the interfaces or the VLANs as I don't think it is necessary.

I will now present the text outputs for each of the switches. Each of these combines the running config, show vlan brief and show interfaces trunk command.


Switch 1:


SW-1#show running-config 
Building configuration...

Current configuration : 1516 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW-1
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/6
 switchport mode trunk
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
!
interface Vlan10
 no ip address
!
interface Vlan20
 no ip address
!
interface Vlan30
 no ip address
!
interface Vlan40
 no ip address
!
interface Vlan50
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

SW-1#sho vlan br

VLAN Name                             Status    Ports

1    default                          active    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24, Gig0/1, Gig0/2
10   VLAN0010                         active    Fa0/1
20   VLAN0020                         active    Fa0/2
30   VLAN0030                         active    Fa0/3
40   VLAN0040                         active    Fa0/4
50   VLAN0050                         active    Fa0/5
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active   

SW-1#show interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/6       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/6       1-1005

Port        Vlans allowed and active in management domain
Fa0/6       1,10,20,30,40,50

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/6       1,10,20,30,40,50
}
____________________________

Switch 2:

SW-2(config-if)#do show running-config
Building configuration...

Current configuration : 1529 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW-2
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 60
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 99
 switchport mode access
!
interface FastEthernet0/6
 switchport mode trunk
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
 duplex half
!
interface Vlan1
 no ip address
!
interface Vlan10
 no ip address
!
interface Vlan20
 no ip address
!
interface Vlan30
 no ip address
!
interface Vlan60
 no ip address
!
interface Vlan99
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

SW-2#sho vl br

VLAN Name                             Status    Ports

1    default                          active    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24, Gig0/1, Gig0/2
10   VLAN0010                         active    Fa0/1
20   VLAN0020                         active    Fa0/2
30   VLAN0030                         active    Fa0/3
60   VLAN0060                         active    Fa0/4
99   VLAN0099                         active    Fa0/5
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active  

SW-2# show interfaces trunk
Port        Mode         Encapsulation  Status        Native vlan
Fa0/6       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/6       1-1005

Port        Vlans allowed and active in management domain
Fa0/6       1,10,20,30,60,99

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/6       1,10,20,30,60,99

__________________________

Switch 3:

SW-3(config)#do show running-config
Building configuration...

Current configuration : 1114 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW-3
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end


SW-3(config)#exit
SW-3#
%SYS-5-CONFIG_I: Configured from console by console

SW-3#sho vl br

VLAN Name                             Status    Ports

1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24, Gig0/1, Gig0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    


SW-3#show interfaces trunk 
Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      1
Fa0/2       on           802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/1       1-1005
Fa0/2       1-1005

Port        Vlans allowed and active in management domain
Fa0/1       1
Fa0/2       1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1
Fa0/2       1

_______________________________

I would be grateful for any help. I can generate any additional info as required. Thanks so much in advance.

EDIT: Adding on the outputs of the show spanning-tree VLAN 10 commands for each of the switches as advised by Ron Trunk. The output for Switch 3 looks suspiciously short.

Switch 1:

SW-1#sho spanning-tree vlan 10
VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     0060.2F6E.6029
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0060.2F6E.6029
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/6            Desg FWD 19        128.6    P2p

Switch 2:

    SW-2#sho spanning-tree vlan 10
VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     0090.2BD9.91EA
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0090.2BD9.91EA
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Desg FWD 19        128.6    P2p
Fa0/1            Desg FWD 19        128.1    P2p

Switch 3:

SW-3#sho spanning-tree vlan 10

No spanning tree instance exists.
5
  • Thanks so much for the edit Ron. Love your last name lol. :)
    – Deepak
    Commented May 16, 2022 at 12:56
  • You're welcome. Nothing jumps out at me. Please include show spanning-tree vlan 10 on each switch.
    – Ron Trunk
    Commented May 16, 2022 at 12:58
  • @RonTrunk I am unfamiliar with this command (still a noob), but I've done as you've asked. I'm sorry, I tried using the pre-formatted text following your example, but it wasn't perfect. Please excuse this. The output for Switch 3 looks suspiciously concise.
    – Deepak
    Commented May 16, 2022 at 13:07
  • Please include in your question which ports are used to connect PC1, PC4, SW1-SW3, SW2-SW3.
    – Zac67
    Commented May 16, 2022 at 13:20
  • @Zac67 Thanks, Ron's answer solved my issue. I really appreciate the help. :)
    – Deepak
    Commented May 16, 2022 at 13:44

1 Answer 1

2

You have not created the VLANs on Switch 3.
You must create the VLAN before you can assign ports to it.

On Switch 3:

Vlan 10
name myvlan
exit
1
  • This immediately solved my issue! Thanks so much. It was a misconception that I had that trunking alone was enough for switch 3, as I thought trunks allow tagged and untagged traffic through without issues. Now I know better. Thanks so much!
    – Deepak
    Commented May 16, 2022 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.