4

I have RB2011UiAS-2HnD-IN router in my network. It has two switches - "switch1" with 5 x 1Gb ports and "switch2" with 5 x 100Mb ports. There is only one LAN addressing pool - 192.168.1.0.

MikroTik - problem with port bridge over LAN using 2 switches

All 5 ports at "switch1" is used. I needed to attache one more device so I connected it to 1st port at "switch2". There is no connection to this device. All 5 ports from "switch1" are in one bridge-local and first port from "switch2" is also attached to this bridge-local. It is also master-port and to him are slaved 4 more ports from "switch2" - so I can only add master to the whole bridge-local ports pool.

I have no cennectivity to my new device. I changed ports for one from "switch1" and everything is working properly. There is problem when I try to use ports from "switch2".

  • You sure? My RB1200 has first 5 ports in one "switch", the rest are independent, and cannot be added to the same "virtual" switch. Those "FastEthernet" switchports are likely not connected to the first 5 gig ports, check in Winbox, open the interface, check the "Switch", the last entry on the first page for the interface. Eg: imgur.com/y3wEKMq – Grizly Sep 23 '14 at 7:26
9

I'd suggest to remove ports from bridge if it is possible to add them to switch group. When your ports are bridged - all packets going through these interface are processed using CPU while, if they would have been in the same switch group, special switch chip would process those packets, decreasing load on CPU.

So, in your case, you can make ether1 to be a master port for ether2-5. Don't forget that before assigning master port you have to remove them from bridge (bridge-local). Then, do the same for the second switch group (ports 6-10), so ether6 will be a master port for ether7-10.

/interface ethernet
  set ether1 master-port=none
  set ether2 master-port=ether1
  set ether3 master-port=ether1
  set ether4 master-port=ether1
  set ether5 master-port=ether1
  set ether6 master-port=none
  set ether7 master-port=ether6
  set ether8 master-port=ether6
  set ether9 master-port=ether6
  set ether10 master-port=ether6

After doing that you'll get two separate and independent switch groups, however, as you mentioned it in your post, you want them to be connected. In such case, there are two options:

  • to use software bridge;
  • connect them using cable.

Software (CPU) bridging

In this case, switch groups 1 and 2 will be switched using CPU, so any packet going from any interface in group 1 to group 2, or vice versa, will be processed using CPU.

/interface bridge
  add name=bridge-local
  port add interface=eth1 bridge=bridge-local
  port add interface=eth6 bridge=bridge-local

NOTE: don't forget to assign an IP address to the bridge and, if you're using DHCP server on Mikrotik, change its interface to bridge-local as well.

/ip address add interface=bridge-local address=192.168.1.1/24
/ip dhcp-server add interface=bridge-local address-poll=[name of your address pool]

Patch cord

Just connect any port from group 1 (ether1-5) to any port in group 2 (ether6-10). Yes, it takes 2 port and only applicable if you have ones. If all ports in one of the switch groups are already in use, I'd suggest using first option (bridging).

Not the answer you're looking for? Browse other questions tagged or ask your own question.