6

I am Cisco certified and have worked for an ISP for the last 5 years. I have made the transition to the LAN side as a Network Administrator so I am a novice at certain things. With that being said, below is the configuration on one of my ASA5520s. I have changed addressing for security, but this is how it looks.

interface GigabitEthernet0/0.2
 nameif Inside
 security-level 100
 ip address 10.x.x.x 255.255.255.248
!
interface GigabitEthernet0/0.4
 nameif DMZ
 security-level 50
 ip address 10.x.x.x 255.255.255.248
!
interface GigabitEthernet0/1
 nameif Outside
 security-level 0
 ip address 159.x.x.x 255.255.255.0

My question is this: I have four physical ports on the back of my ASA, why don't they show up in the running config ,,,why?

And my second question: is it ok not to have a VLAN associated with my sub-interfaces?

2
  • 4
    Please add output from "show context", "sh version" and "show mode"
    – This
    Jul 28 '14 at 20:41
  • Did any answer help you? If so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you can post and accept your own answer.
    – Ron Maupin
    Jan 5 at 1:34
3

In a word: LICENSE

It could be your license only allows 2 physical interfaces. show version will show your licensed features.

3
  • 1
    The license could affect the vlan limit. However, I am unaware of any base level ASA which has a limit on the physical connections that doesn't match the actual count of physical connections. The ASA5520 should have 4 GE and 1 FE available for use. Sounds like he is in a context. Jul 28 '14 at 23:56
  • I agree, he's most likely in a context, but physical interfaces is a field in the license data. (if they are allowed to operate at gig is as well)
    – Ricky
    Jul 29 '14 at 1:20
  • Yes, but all licenses support all the physical ports. None of them actually restrict the physical ports available. For gig vs fast ethernet, only the 5510 has a license for gig (Sec+ license) which enables gig on 2 of the 5 fast ethernet ports. The 5520 and higher has no license restriction for gig. Jul 29 '14 at 2:18
0

Log into the admin context to see the number of interfaces, or use Cisco ASDM if you are a novice with the ASA, it will provide you with a good view of the configuration and performance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.