I have a pair of Cisco 2960-X's in a stack configuration using stack modules. This gives me a total of 4, 10 gbps SFP+ slots. I am using interfaces Te1/0/1 and Te2/0/1 as 10 gbps uplinks to the core and previously had Te1/0/2 and Te2/0/2 open.

Now I need to add a 1 gbps link coming off of one of these switches out to another device which only supports 1 gbps fiber SFP modules. I hooked up a 1 gbps SFP module to the Te2/0/2 interface, however it continued to show the type as "Not Present".

After working at it for a bit I reloaded the switch to find that the list of interfaces had changed to now show a Gi2/0/49 and Gi2/0/50 while now missing Te2/0/2. (As a side note the Gi2/0/49 interface shows "Not Present" while the Te2/0/1 interface shows the 10 gbps SFP+ module). Gi2/0/50 now shows the 1 gbps SFP and works correctly.

Is there any way for the switch to perform this detection process without having to reboot it? I may have to swap these around again in the near future and I would rather not cause downtime for the other systems that are plugged into that switch if it can be avoided.

  • Looks like this has not been answered yet? I tried shut/no shut and it did not work. I did not try reload but just unplugged the switch in the stack and SFP worked after that. Is there a way to enable the SFP ports without rebooting?
    – user15285
    Commented May 6, 2015 at 15:53
  • This question has been answered and accepted, by RedShift networkengineering.stackexchange.com/a/10367/253 Please see that answer, it lists a couple of IOS bugs and recommends an upgrade.
    – Baldrick
    Commented May 6, 2015 at 20:49

2 Answers 2


Maybe these bugs are affecting you:

  • CSCuj74167 (Gigabyte link from WS-C2960X-48FPD-L not coming up when using GLC-SX-MM) applies to you. Fixed in software release 15.0(2)EX4.
  • CSCul88801 (1G or 10G in uplink ports of a Catalyst 2960x stack may not come up after a reload or OIR of SFP/SFP+. 1G or 10G SFP appear as “unknown” in the output of the show int status command.). Fixed in software release 15.0(2)EX5.

So before looking any further, I'd upgrade to at least 15.0(2)EX5. (Which is the latest stable available for 2960X as of this writing).


Based on Cisco Gigabit Ethernet Transceiver Modules Compatibility Matrix 1G SFP's are supported. (GLC-T is in there.)

Q. Can the 10 Gigabit SFP+ slots on the Cisco Catalyst 2960-X model support 1 Gigabit SFP modules?
A. Yes. The Cisco Catalyst 2960-S models that support 10 Gigabit SFP+ modules can also support SFP modules that operates at 1 Gigabit.
Q. Can the 10 Gigabit SFP+ slots on the Cisco Catalyst 2960-X models support 100-Mb SFP modules?
A. No. The Cisco Catalyst 2960-X models that support 10 Gigabit SFP+ modules cannot support SFP modules that operate at less than 1 Gigabit.

2960-X Series Q & A (note the 2960-S typo)

  • I understand that they're supported and I've managed to get it working. What I'm wondering is if there's a way to get the switch to detect the 1 gbps modules without having to reload that particular switch in the stack.
    – Bad Wolf
    Commented Aug 5, 2014 at 13:32
  • shut then no shut? The whole point is to be hot-plugable. If they aren't, only Cisco can do anything about that. I found no reference to any procedures for installation or removal of the SFP/SFP+.
    – Ricky
    Commented Aug 5, 2014 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.