3

I am trying to replace the startup configuration on Cisco Nexus device using a file on remote server. I tried the instructions given at this page:

Working With Configuration Files: Downloading the Startup Configuration From a Remote Server

So, I tried running command copy tftp://<server-ip-address>/nexus-startup.cfg startup-config and got the following output with error:

Nexus7K01# copy tftp://172.16.38.4/nexus7k01.cfg startup-config
Enter vrf (If no input, current vrf 'default' is considered): management
Trying to connect to tftp server......
Connection to Server Established.
TFTP get operation was successful
sysmgr_copy_nvram_dest_action: src uri_type = 2 is not supported yet
Nexus7K01#

I tried to copy the file using all the four remote server protocol and got the same error with different URI type. 1 for FTP, 128 for SCP and 512 for SFTP.

The device is a Cisco Nexus 7000 series device with following details:

Software
  BIOS:      version 3.22.0
  kickstart: version 6.1(3)
  system:    version 6.1(3)

Hardware
  cisco Nexus7000 C7010 (10 Slot) Chassis ("Supervisor module-1X")
  Intel(R) Xeon(R) CPU         with 8251588 kB of memory.

Please let me know what am I doing wrong and how can I rectify this error.

Thanks in advance!

-Varun

3
  • 1
    Is tftp:/// a typo? It should be tftp:// You also did not include a server in the URL. Aug 6, 2014 at 14:47
  • Unfortunately, all I can add is that this works OK on my Nexus 4000 blade switch. But it runs a different version (4.1(2)E1(1i)) and is a different type of switch. It does warn that it is deprecated with This command is deprecated. To obtain the same results, please use the sequence 'write erase' + 'reload' + 'copy <file> running-config' + 'copy running-config startup-config'. Aug 6, 2014 at 15:15
  • I have updated the question with complete output from the device. Moreover, when I use similar command to copy the same file to bootflash, it works fine. So, there is no typo in the command. I can't use the set of commands that you have given because I am trying to run these commands remotely by opening a CLI session and when I do "write erase", it clears out the startup configuration and on "reload", the switch starts up with an empty configuration and so I am not able to open a CLI session to the device. If there is a way to run these commands remotely from a CLI session, please let me know Aug 6, 2014 at 15:51

2 Answers 2

4

I would first check that you correctly have the 'nexus-startup.cfg' in your TFTP root folder, so that it's not a path issue. I suggest this because the uri error your getting would suggest the path is not found. Also - you'll need to address your syntax. Following from Nx-OS contextual help:

 tftp:  Enter URL "tftp:[//server[:port]][/path]"

Also - I would try just copying it to your flash and then to startup-config after that if it's not liking the syntax you used to copy it over.

UPDATE:

This known issue with your NX-OS version could be related, or even the root cause:

CSCud05567
Symptom : Following a system switchover, copying to bootflash on the supervisor module does not work.

Conditions : This symptom might be seen under normal operating conditions for a Cisco Nexus 7000 Series device.

Workaround : None.

Source is HERE

The good news is that this issue is only appearing from 6.1, so if you are in a position to move down to 6.0 family of NX-OS you should be good. My personal preference anyway is to stay a family behind the latest and greatest unless there's a security patch.

6
  • The file is correctly present in the TFTP root folder as I am able the same file to the device locally on bootflash. Also, I have updated the full output of the command in the question. Please observe that GET operation was successful, but it is not able to somehow write it to the startup-configuration Aug 6, 2014 at 15:53
  • Ok cool - glad to hear you can at least copy it over, and then from there you copy copy flash:blah startup-config. My best guess Varun - is that the syntax just isn't supported in your IOS version using 'startup-config' - you should try qualifying it wish 'flash:startup-config'.
    – A L
    Aug 6, 2014 at 17:47
  • Let me know if that works and I'll update the answer to be more authoritative
    – A L
    Aug 6, 2014 at 17:52
  • 1
    It has something to do with the version of NX-OS on the device although the message is not very descriptive. For e.g., I can run the command copy tftp://172.16.38.4/nexus7k01.cfg bootflash:startup-config but the startup config used by the switch is present in the nvram: filesystem. So then I gave the command to copy the startup-config present in the bootflash: filesystem over to nvram: but got the below output Nexus7K01# copy bootflash:startup-config nvram:///startup-config This command is not supported in this release So, somehow the operation is not supported. Not sure how to fix it. Aug 7, 2014 at 11:54
  • That sucks man, I posted an update.. Let me know how you feel about that.
    – A L
    Aug 7, 2014 at 14:17
0

my understanding is NX-OS does not support copying from remote file system directly to NVRAM:.

The work around is to first copy the file to bootflash, then to copy from boot flash to NVRAM:

ie.

copy ftp://user:password@server/config.cfg bootflash:///config.cfg
copy bootflash:///config.cfg startup-configuration

hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.