4

We have two separate networks with SRXes on both sides (router, firewall, and site2sitevpn).

On one side (Site A), we have two ISPs (BGP), and currently the VPN is setup to the IP address of one of our ISP (ISP1). but if ISP1 line should go down our VPN also goes down. is there a way to Automatically change the VPN tunnel IP address to the IP of the second ISP (ISP2) in the event that ISP1 should go down? or is that a stupid way to do it?

Is is perhaps better to setup a 2nd VPN tunnel to the ISP2 IP address? if so, how can I automatically start the 2nd VPN if 1st fail?

Map:

explanations of network

PS: site A has its own AS and ip series, and used BGP to route traffic to/from the two ISPs

UPDATE 1:

I have some clarifications, and also some new information (to futher complicate things).

1) SITE A has only one SRX, with each ISP on a separate port. ge-0/0/4 = isp1 ge-0/0/3 = isp2

today the site2site vpn St0 (used ip range 192.168.21.0/30 on the vpn), uses only isp1, but I would like to have isp2 as a backup.

2) Site B actually only has one ISP, but they have given us 2 different IP addresses, one of the addresses uses a special routing to their upstream provider (but only that network!), wheras the other IP address uses BGP and will use whatever routing upstream work.. so we have vlan.12 ip address 1) 6.6.6.6/29 (the one we use today) vlan.12 ip address 2) 5.5.5.5/29 (another ip we also want to use).

So, the ip 6.6.6.6 gives us very fast speeds between the offices, as the route goes to the shortes path.. but it is limited to one provider, so the chance that it goes down is quite high. ip 5.5.5.5 is quite a bit slower, but is more robust to faults between the two networks.

further explanations of network

In the image above, you can see in red where the site2site vpn goes today. So in the end I would like to have redundancy so that all 4 combinations should work.

  1. WAN1 - WAN-A
  2. WAN1 - WAN-B
  3. WAN2 - WAN-A
  4. WAN2 - WAN-B

noteA: vlan.12 is just a vlan that could easily have been a port such as ge-0/0/2, I have just setup the vlan to be able to use other physical ports on the SRX just in case.

noteB: SITE B only uses one physical port to one and same ISP, but uses two different IP addresses.

thanks again for the help so far. I will setup a service window to test tome of these things soon.

update2:

BGP setup on SiteA:

protocols {
    bgp {
    group bgp-ISP2 {
        preference 290;
        local-address 8.8.8.9;
        log-updown;
        import import-bgp-ISP2;
        authentication-key "somekey"; ## SECRET-DATA
        peer-as <ASNUMBER>;
        neighbor 8.9.7.6 {
            export export-bgp-ISP2;
        }
    }
    group bgp-ISP1 {
        preference 250;
        local-address 7.7.7.8;
        log-updown;
        import import-bgp-ISP1;
        authentication-key "somekey"; ## SECRET-DATA
        peer-as <ASNUMBER>;
        neighbor 7.8.9.1 {
            export export-bgp-ISP1;
        }
    }
}
}
  • How are you deciding which route to take on each device? Are you relying on routing protocols, static routing or routing instances etc? If you want to use the multiple gateway option I listed below you will have problems setting the external-interface option in the IKE stanza. Depending on your config you might need to look at binding your tunnel to a loopback adapter and going from there. This can also have issues though as there are some limitations. Can you post any config? – Gareth Hastings Aug 13 '14 at 6:10
  • I am a little worried about posing configs.. any way I can send you privately? – Sverre Aug 13 '14 at 6:50
  • Without posting config you could say how you handle routing between the two providers at each site? – Gareth Hastings Aug 13 '14 at 8:26
  • on site A, we use BGP to route between the two. I will post psudosetup above, one sec. on site B, right now we only have the one ip address and it is the default route (2nd ip is not up at all right now). – Sverre Aug 13 '14 at 9:15
8

Junos does have DPD and you can use it in conjunction with multiple endpoint IP addresses in a single IKE tunnel.

There is a bit of info about it here (which I've copied below)

http://kb.juniper.net/InfoCenter/index?page=content&id=KB29211&actp=RSS

SUMMARY: This article explains how redundancy in site-to-site VPN can be achieved using multiple address in gateway and dead-peer-detection.

PROBLEM OR GOAL: How to use different modes of dead-peer-detection for VPN failover .

CAUSE:

SOLUTION: The gateway for VPN redundancy can be configured with the following commands :

set interfaces fe-0/0/0 unit 0 family inet address 1.1.1.2/24
set interfaces st0 unit 0 family inet
set routing-options static route 0.0.0.0/0 next-hop 1.1.1.1
set security ike policy p1 mode main
set security ike policy p1 proposal-set standard
set security ike policy p1 pre-shared-key ascii-text "$9$21oZjmfzCtOHqtO1RlegoJ"
set security ike gateway g1 ike-policy p1
set security ike gateway g1 address 2.2.2.1
set security ike gateway g1 address 3.3.3.1
set security ike gateway g1 dead-peer-detection interval 10
set security ike gateway g1 dead-peer-detection threshold 3
set security ike gateway g1 external-interface fe-0/0/0
set security ipsec policy p1 proposal-set standard
set security ipsec vpn v1 bind-interface st0.0
set security ipsec vpn v1 ike gateway g1
set security ipsec vpn v1 ike ipsec-policy p1
set security ipsec vpn v1 establish-tunnels immediately

The first address in the order of configuration is the one chosen to negotiate the tunnel:

gateway g1 {
            ike-policy p1;
            address [ 2.2.2.1 3.3.3.1 ];
            dead-peer-detection {
                                 interval 10;
                                 threshold 3;
                                 }
            external-interface fe-0/0/0;
            }

The above configuration is in dead-peer-detection optimal mode. It sends probes if packets were sent out (encrypted packets), but no packets were received (decrypted) for the configured interval. Three probe-packets are sent at 10 second intervals.

root@srx# run show security ike sa 
Index State Initiator cookie Responder cookie Mode Remote Address 
6770125 UP d570a30c806721ea ccc1572d2f763981 Main 2.2.2.1 


root@srx# run show security ipsec sa 
Total active tunnels: 1
ID Algorithm SPI Life:sec/kb Mon lsys Port Gateway 
<131073 ESP:3des/sha1 1debda06 3397/ unlim - root 500 2.2.2.1 
>131073 ESP:3des/sha1 7a7dff24 3397/ unlim - root 500 2.2.2.1

As soon as the tunnel drops, dead-peer-detection comes into play. If a response is not received from the peer in 30 seconds, the failover takes place and the tunnel is negotiated with 3.3.3.1 and vice-versa.

root@srx# run show security ike sa
Index State Initiator cookie Responder cookie Mode Remote Address 
6770151 UP 36a2e145e0fd2c10 b3abc0b135cf33fe Main 3.3.3.1

root@srx# run show security ipsec sa 
Total active tunnels: 1
ID Algorithm SPI Life:sec/kb Mon lsys Port Gateway 
<131073 ESP:3des/sha1 2420b2bd 3598/ unlim - root 500 3.3.3.1 
>131073 ESP:3des/sha1 5c8bb9da 3598/ unlim - root 500 3.3.3.1

Always-Send mode for dead-peer-detection:

In order to instruct the device to send dead-peer-detection requests, regardless of whether or not there is outgoing IPSec traffic to the peer, the following command is also needed:

set security ike gateway g1 dead-peer-detection always-send

UPDATE

I have configured this in a test lab and confirm that it works well. I have 3 devices, S3, S4 and S5.

S4 and S5 both have a basic IPSEC tunnel configured to connect to S3 (7.7.7.22 in my example). The config is dead simple and the same on both devices

ike {
    gateway s3-gw {
        ike-policy ike-policy;
        address 7.7.7.22;
        external-interface ge-0/0/1.0;
    }
}
ipsec {
    policy standard-ipsec-policy {
        proposal-set standard;
    }
    vpn s3 {
        bind-interface st0.0;
        ike {
            gateway s3-gw;
            ipsec-policy standard-ipsec-policy;
        }
        establish-tunnels immediately;
    }
}

The device S3 has a config that is very similar to the above but has 2 gateways listed and DPD enabled.

The relevant section is in the IKE config

gateway s4-s5-gw {
    address [ 7.7.7.21 192.168.211.2 ];
    dead-peer-detection {
        always-send;
        interval 10;
        threshold 3;
    }
    external-interface ge-0/0/1.0;
}

This brings up the tunnel as such

root@TEST-srx3> show security ike security-associations
Index   State  Initiator cookie  Responder cookie  Mode           Remote Address
1404200 UP     2f4f0465dc8c4556  d2e6022d0dc213c3  Main           7.7.7.21

root@TEST-srx3> show security ipsec sa
  Total active tunnels: 1
  ID    Algorithm       SPI      Life:sec/kb  Mon lsys Port  Gateway
  <131073 ESP:3des/sha1 d4428f3  3170/ unlim   -   root 500   7.7.7.21
  >131073 ESP:3des/sha1 5cda9108 3170/ unlim   -   root 500   7.7.7.21

If I deactivate the IKE/IPSEC config sections on S4 the tunnel drops and then comes back up connected to the 2nd gateway

root@TEST-srx3> show security ike security-associations

root@TEST-srx3> show security ipsec sa
  Total active tunnels: 0

Then after about 30 seconds (10 x 3)

root@TEST-srx3> show security ike security-associations
Index   State  Initiator cookie  Responder cookie  Mode           Remote Address
1404202 UP     35e54d457be6132f  0444ae31577c71a2  Main           192.168.211.2

root@TEST-srx3> show security ipsec sa
  Total active tunnels: 1
  ID    Algorithm       SPI      Life:sec/kb  Mon lsys Port  Gateway
  <131073 ESP:3des/sha1 93043b2  3595/ unlim   -   root 500   192.168.211.2
  >131073 ESP:3des/sha1 e5c551e4 3595/ unlim   -   root 500   192.168.211.2

If you need any help post some config snippets and I'll do my best to have a look!

UPDATE 2

I have built this whole thing in a mini lab. The problem I have found is that while you can use multiple gateways in your IKE configuration you will still need to have an IPSEC tunnel per ISP on each device. This is because you have multiple source IP addresses you want to potentially make an IPSEC tunnel from.

Lab Config

To save me posting a lot of config each SRX (A and B) has two IPSEC tunnels configured as shown below. The things to note are I'm using a single tunnel interface on each device, these are set to multipoint. You could use multiple ones if you wanted.

This config will provide full redundancy if a single ISP at site A and/or site B goes down.

I tested this by dropping the linked between SRX-A and SRX-1 and then dropping SRX-B and SRX-4. Due to me using BGP and DPD it took just over a minute for the tunnel to come back up but worked well!

Hopefully this will ultimately help you sort out your config!

SRX-A IPSEC Config

ike {
    gateway SRX-B_via_ISP1 {
        ike-policy ike-policy;
        address [ 6.6.6.6 5.5.5.5 ];
        dead-peer-detection {
            always-send;
            interval 10;
            threshold 3;
        }
        external-interface lo0.10;
        local-address 7.7.7.5;
    }
    gateway SRX-B_via_ISP2 {
        ike-policy ike-policy;
        address [ 6.6.6.6 5.5.5.5 ];
        dead-peer-detection {
            always-send;
            interval 10;
            threshold 3;
        }
        external-interface lo0.10;
        local-address 8.8.8.9;
    }
}
ipsec {
    policy standard-ipsec-policy {
        proposal-set standard;
    }
    vpn SRX-B_via_ISP1 {
        bind-interface st0.0;
        ike {
            gateway SRX-B_via_ISP1;
            ipsec-policy standard-ipsec-policy;
        }
        establish-tunnels immediately;
    }
    vpn SRX-B_via_ISP2 {
        bind-interface st0.0;
        ike {
            gateway SRX-B_via_ISP2;
            ipsec-policy standard-ipsec-policy;
        }
        establish-tunnels immediately;
    }
}
| improve this answer | |
  • Thanks, I have tried to add multiple ips, but would not commit, but I will read trough your proposal more closely and try again, thanks for input, I will get back to you when I have had time to give it a go. – Sverre Aug 8 '14 at 9:05
  • Thanks Gareth for sharing the actual commands, cool stuff ! – A L Aug 8 '14 at 14:38
  • Thanks for adding even more good commands! I will study, test and get back to you. – Sverre Aug 13 '14 at 2:31
  • your explanations are very excellent, but there are some differences to my case, (and I also have one more complication for you. 1) in my case, I only have 2x SRX boxes, one on each side (you have S4 and s5 as separate boxes, but in my case they are only two separate ports on the same srx), also 2) on my other side (s3 in your case), this box actually have 2 different IPs from the ISP, and I would like to also make both IPS used.. in the event that one of the lines should go down. (it is routed to a smaller part of my ISP network). I will try to add an explanation in an edit above – Sverre Aug 13 '14 at 4:55
2

not sure how it works on Juniper, but if there is any sort of dead peer detection you can do in your VPN setup I'd do it. On Cisco devices, we set multiple peers and use DPD to push it over when the first peer fails.

Assuming DPD isn't an option on Juniper, an easy way to do it would be to setup another VPN tunnel to Site B using ISP2's IP address as the endpoint, and use routing (don't know what proto you use inside) to create a secondary path between your sites with a higher administrative distance, that way when the route over your primary tunnel (the lower admin distance) dies, and is removed from your table, the secondary route gets selected, and your tunnel comes up between ISP2 and SITE B.

If you post more details I can give you more as well.

| improve this answer | |
  • thanks, there is a dead peer system in juniper, I am currently looking into that more, and will try some things. thanks. – Sverre Aug 8 '14 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.