0

On an ASA5505 version 8.2, I have three internal IP subnets that I want to:

  • Pass traffic between as if they were on the same subnet
  • Share the same gateway
  • Share the same VLAN

I've been working to configure a solution that I found here: http://itknowledgeexchange.techtarget.com/it-rant/adding-a-secondary-address-to-an-interface-on-a-cisco-asa/

and here:

http://www.ducea.com/2008/05/31/adding-a-secondary-ip-address-on-a-cisco-asa-ethernet-interface/

Unfortunately, I am having trouble getting it to work.

I've pasted my current config below:

ASA Version 8.2(5)
!
hostname ciscoasa
enable password xxencrypted
passwd xx encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
 switchport access vlan 2
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 mac-address 88f0.3175.5e78
 nameif inside
 security-level 100
 ip address 10.11.10.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp
!
interface Vlan5
 nameif dmz
 security-level 50
 ip address 10.11.13.1 255.255.255.0
!
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit tcp any any eq www
access-list outside_access_in extended permit tcp any any eq https
access-list inside_nat0_outbound extended permit ip 10.11.10.0 255.255.255.0 10.11.11.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm history enable
arp inside 10.11.12.254 88f0.3175.5e78 alias
arp inside 10.11.11.254 88f0.3175.5e78 alias
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route inside 10.11.11.0 255.255.255.0 10.11.10.254 1
route inside 10.11.12.0 255.255.255.0 10.11.10.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.11.10.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto isakmp nat-traversal 3600
telnet 10.11.10.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username xx password xx encrypted privilege 15
!
!
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:xxx
  • 2
    What do you mean by share the same gateway? In this case, I suspect that the ASA is the gateway. They cannot share the same default gateway and be on different subnets – David Houde Aug 8 '14 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.