1

To connect two Catalyst switch stacks, I use EtherChannel, i.e. I aggregate several ports on each switch to get more bandwidth and higher availability than with just a single port.

However, the link doesn't work yet. What could cause the problem?

  • 3
    Could we see some config snippets? – Yosef Gunsburg May 26 '13 at 18:34
  • 2
    Apart from configuration, it would be useful to have the output of show etherchannel summary in both switches. – Daniel Yuste Aroca May 26 '13 at 18:53
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 9 '17 at 15:42
  • @RonMaupin What do you think - did any answer help? Any wild guess? Yes, I could provide an answer. Or did I? Taking a look can help. I could "accept" and did it after such comments, but now I got many "automated" copies of such requests. – Stefan Aug 9 '17 at 16:21
  • If your answer helped, you should accept it. The question will keep popping up forever, looking for an answer if there is not accepted answer. If you believe your answer is correct, then you should accept it. Nobody else can do this, and the question will keep popping up until you accept an answer. That is how SE works. – Ron Maupin Aug 9 '17 at 16:23
7

Improperly configured EtherChannel (port-channel) interfaces would be disabled automatically, to prevent problems such as loops. First of all, having the same configuration on each side would be the safest.

Here's a checklist:

  • Both switches must see the ports as an EtherChannel bundle. If one switch would consider ports as separate connections, it's inconsistent and would fail.

  • All ports in the bundle needs to have the same EtherChannel protocol, i.e. don't mix PAgP and LACP. Also manual configuration mixed with one protocol is not recommended.

  • All channel ports must use at the same speed and the same duplex mode. And LACP doesn't support half-duplex.

  • No one of the ports can be SPAN (switched port analyzer) destination port.

  • If the channel is layer 3, give the address to the port-channel interface, not to single ports.

  • For layer 2 channels:

    • All ports have to be either trunks or in the same VLAN.
    • If trunking is used, the mode has to be the same on all ports.
    • If you use a trunk with an allowed VLAN range, that range must be the same on all ports.
    • If you would have different STP costs in a channel, at least ports have to be compatible to each other. STP considers an EtherChannel as a single port.
    • Protocol filtering has to be the same on all ports.
    • Also here, (static MAC) addresses must be on the port-channel interface, not on single ports.

Further reading:

| improve this answer | |
  • 1
    And use LACP (or PAgP if you must), there's no justification for manual etherchannels these days. – LapTop006 May 26 '13 at 13:49
  • Another possibility if you're using LACP is having minlinks set too high. – LapTop006 May 26 '13 at 13:49
0

Depending on how old the switches are you may need to configure the "switchport trunk native vlan xxx" on the Port Channel interface on both sides.

| improve this answer | |
0

You would need to go into interface configuration mode for the port range of your ether channel and make sure the ports are enabled as differently than the port-channel itself being enabled.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.