1

I'm trying to set up some simple routing rules for the following scenario:

XO LAN : 172.x.x.x X1 WAN: 64.x.x.x X2 WAN: 199.x.x.x X3 SIP: 192.168.28.1

X3 has a PBX 192.168.28.2 directly connected to it and I'm trying to route it to only use X2's WAN. Obviously I can ping the X3 Interface from .2 but no routing rules are set up for this and after trying a few, I thought I'd ask for help. It should be simple but I'm not seeing it. Any help is highly appreciated.

3

Go to Network->Routing. Add a new Route Policy.

  • Source = PBX (192.168.28.2)
  • Destination = Any
  • Service = Any (or the specific services you want routed over X2)
  • Gateway = X2
  • Default Gateway Interface = X2
  • Metric= something less than 20 (10?) so that it preempts the other route policies.

That should do it.

  • I actually figured it out before seeing you post here but now I have another issue with NAT. The rule was already there but a NAT policy was overriding it. What I'm trying to do is have a Public Ip address NATted for the 192.168.28.2 but the typical outbound policy I use is interfering. – IT headache Aug 20 '14 at 16:45
  • Thanks for the help. I'll add a followup question if I can figure out what is going on here. – IT headache Aug 20 '14 at 16:46
  • Can you post a screenshot of your NAT rules? Probably a good idea to start a new question as well. – Jim G. Aug 20 '14 at 21:50
  • I actually got it all straightened out. It was actually IP Spoofs causing problems and I had them turned off by the hidden diag.html page but I thought I was having NAT/Routing issues when it was just spoofs because of different subnets talking across interfaces. You answered quickly and I appreciate it. I'll probably have more questions because I'm in a large PBX install project bringing SIP in over the internet to Avaya IP Office PBX's. I've heard of NAT issues with SonicWalls and SIP and it might come to bite me in the next couple of days. I'll post a new question when it arises. – IT headache Aug 21 '14 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.