1

I've configured my pfSense router with two bridged WAN to a DMZ (OPT2). Everything is fine to access web server from external with public IP directly on servers behind DMZ.

The setup is pretty much the same as : http://doc.m0n0.ch/handbook/examples-filtered-bridge.html

The only bad thing, I can't access these web servers from behind the LAN (which is NATed). Exactly as described in the same example : http://doc.m0n0.ch/handbook/faq-bridge.html

I was thinking about having two routers (one bridge and one NAT) because I have 8 IPs for each WAN so it could be possible. But this is not interresting, is there any other turn arround?

  • Do you have automatic NAT turned on? Have you tried using manual NAT? Sounds like you need some kind of NAT exemption but I'm not sure how it works on pfsense. – Daniel Dib Aug 31 '14 at 7:37
  • I'm currently using Manual Outbound NAT rule generation (AON - Advanced Outbound NAT), with my two WANs. It looks like I can disable NAT on certains rules but it looks most like chinese for me right now! – Alexandre Lavoie Aug 31 '14 at 10:30
1

Finally by trial and error I've found a solution, I don't know if this is the state of the art solution, but it is working perfectly.

1 Create a new Gateway

  • Systems > Routing > Gateways
  • Add Gateway
  • Select the interface that is your DMZ
  • Give a name and leave without IP (dynamic)

2 Create Firewall Rules

  • Firewall > Rules > LAN
  • Create a rule before default LAN with source : any, destination : single host with Bridged IP, advanced feature gateway : The gateway you created.

I've created a rule for each bridged IP, since I don't bridge all IPs I've done it so.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.