3

How can I configured MPLS-TE FRR on IOS using tunnels with dynamic paths (Is this even possible, I think it might be IOS-XR only)?

enter image description here

In this topology I have a full mesh of MPLE-TE tunnels configured. Below is the R1 configuration but all nodes are the same just with the IPs changed.

I want to test FRR between R1 and R3. Under Tunnel3 on R1 (and Tunnel1 on R3) I have one dynamic path configured (I'd like to follow the IGP in this example). Looking over Cisco documentation for MPLS-TE FRR at lesat one explicit path seems to be in all examples I can find. If I add a 2nd path to the tunnel interface on each router (R1-Tu3 and R3-Tu1) that is also configured as dynamic can I use FRR, and how?

I don't know how to configure FRR without an explicit path (only theorise how it might work but my mental hypothesis seems sup-optimal - which is why I'm not sure its even achievable).

mpls traffic-end tunnels
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 1 area 0
!
interface Tunnel2
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.0.0.2
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 dynamic
 tunnel mpls traffic-eng fast-reroute
!
interface Tunnel3
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.0.0.3
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 dynamic
 tunnel mpls traffic-eng fast-reroute
!
interface Tunnel4
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.0.0.4
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 dynamic
 tunnel mpls traffic-eng fast-reroute
!
interface FastEthernet0/0
 ip address 10.0.12.1 255.255.255.0
 ip ospf 1 area 0
 mpls traffic-eng tunnels
!
interface FastEthernet0/1
 ip address 10.0.14.1 255.255.255.0
 ip ospf 1 area 0
 mpls traffic-eng tunnels
!
router ospf 1
 router-id 10.0.0.1
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
6

'Backup Auto Tunnels' are what you're after.

http://www.cisco.com/c/en/us/td/docs/ios/mpls/configuration/guide/12_2sy/mp_12_2sy_book/mp_te_autotunnel.html#wp1055333

The way you've currently set it out would need 'mpls traffic-eng backup-path' on the protected links. However this is the static backup tunnel way and if you use 'dynamic' paths the LSP will always signal using best IGP paths. Your protection paths will not be protected by a backup as the backup would try to use the same IGP path (due to lowest metric).

This is why an explicit path is necessary in IOS when using static backup tunnels as it allows the software to determine the alternate path that can provide protection.

Have a read about 'auto tunnel backup' and it should resolve your query. IOS and IOS-XR both support Auto tunnels.

| improve this answer | |
  • That is what I was looking for. show mpls traffic-eng tunnels tunnel X protection shows that my tunnels now have backup tunnels which egress via a different local interface. Yes I agree dynamic paths will always follow the IGP but I was hoping there was a way for a backup tunnel LSP to be created using the next best IGP path which this command seems to do. – jwbensley Sep 8 '14 at 9:19
  • Excellent. Glad you've found what you needed. – APA Sep 9 '14 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.