2

I am trying to setup a cisco 2811 router for a lan party. So Far I have the following configuration. The router can ping the "outside" lan, but nothing from "inside" can see out.

ena

conf term

no ip domain lookup
no logging console

ip dhcp pool Main
 network 172.16.0.0 255.255.0.0
 default-router 172.16.0.1
 dns-server 4.2.2.1

exit

int Fa0/0

ip access-list standard 1
 permit 172.16.255.255
 deny any
 exit

interface FastEthernet0/0
 ip address 172.16.0.1 255.255.0.0
 duplex auto
 speed auto
 no shutdown
 ip nat inside


interface FastEthernet0/1
 no shutdown
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto



exit

ip nat inside source list 1 interface FA0/0
ip route 0.0.0.0 0.0.0.0 FA0/1


exit
4

Your translation is not correct.

You should use ip nat inside source list 1 interface "FA0/1 overload" instead of FA0/0

remember your outside interface is Fa0/1 and you want your LAN to exit through that interface IP

Ravi

| improve this answer | |
1

Unless you only want address 172.16.255.255 to be NAT'ed that access-list is wrong. It should be:

ip access-list standard 1
 permit 172.16.0.0 0.0.255.255
 deny any
 exit
| improve this answer | |
  • 1
    Oops, goofed that part up. Still is not working quite right yet. – epl692 Sep 14 '14 at 11:05
  • Need a little more info to troubleshoot. Is your PC behind a switch or directly connected to fa0/0? Can you post a 'sh int fa0/1' ? Or a sh ip int brief to verify that your fa0/0 wan interface is getting its dhcp address from the isp provider? From the router, can you try 'ping 4.2.2.1 source fa0/1' & also from fa0/0 – LucentMoon Sep 14 '14 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.