6

I'm trying to set up a DMVPN Phase 2 configuration, but I cannot manage to get past Phase 1 because the hub router's tunnel interface refuses to disable split-horizon. The spokes never form an EIGRP adjacency to teach other and never learn routes directly to the other spokes.

I'm looking for suggestions on something I may be doing wrong. I've tried disabling on the interface itself and in the routing configuration as well just be sure. When I check the interface, it still says split horizon is enabled.

I haven't added any optimizations commands yet or anything unnecessary to establish communication. Once I can get my spokes talking directly, I'll worry about improving the configuration. This is solely a test environment right now.

EDIT: To clarify, the fact that spokes receive no routes to other spokes and never form adjacencies tells me that split horizon is still on. The Tun1601 interface shows split horizon still enabled. Sh ip eigrp interface says thats its disabled. Short of taking a packet capture and investigating what's really happen, it seems it is in fact not disabled.

Hub:

interface Tunnel1601
 description DMVPN over INTERNET
 bandwidth 1000
 ip vrf forwarding Green
 ip address 172.17.13.7 255.255.252.0
 no ip redirects
 ip mtu 1400
 no ip split-horizon eigrp 1601
 ip nhrp authentication NHRPKey2
 ip nhrp map multicast dynamic
 ip nhrp network-id 1601
 ip nhrp holdtime 300
 ip nhrp registration timeout 30
 tunnel source Port-channel2.7
 tunnel mode gre multipoint
 tunnel key 100001
 tunnel vrf INTERNET
 tunnel protection ipsec profile IPSEC-INTERNET

router eigrp DMVPN-INTERNET
 !
 address-family ipv4 unicast vrf Green autonomous-system 1601
  !
  af-interface Tunnel1601
   no next-hop-self no-ecmp-mode
   no split-horizon
  exit-af-interface
  !
  topology base
  exit-af-topology
  network 172.17.12.0 0.0.3.255
  network 172.30.3.0 0.0.0.255
  network 172.30.6.0 0.0.0.255
 exit-address-family

Sh ip int tun1601:

Tunnel1601 is up, line protocol is up
  Internet address is 172.17.13.7/22
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1400 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Multicast reserved groups joined: 224.0.0.10 224.0.0.251
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are never sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF switching turbo vector
  IP Null turbo vector
  VPN Routing/Forwarding "Green"
  Associated unicast routing topologies:
        Topology "base", operation state is UP
  Tunnel VPN Routing/Forwarding "INTERNET"
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  Input features: MCI Check, TCP Adjust MSS
  Output features: TCP Adjust MSS
  Post encapsulation features: IPSEC Post-encap output classification
  IPv4 WCCP Redirect outbound is disabled
  IPv4 WCCP Redirect inbound is disabled
  IPv4 WCCP Redirect exclude is disabled

@cpt_fink

sh ip eigrp vrf Green int

EIGRP-IPv4 VR(DMVPN-INTERNET) Address-Family Interfaces for AS(1601)
           VRF(Green)
                              Xmit Queue   PeerQ        Mean   Pacing Time   Multicast    Pending
Interface              Peers  Un/Reliable  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Tu1601                   1        0/0       0/0          62       0/22         252           0
Lo2                      0        0/0       0/0           0       0/0            0           0
Gi0/1                    0        0/0       0/0           0       0/0            0           0
  • Aren't IP split-horizon and EIGRP split-horizon are different? And either way EIGRP split-horizon won't affect the formation of an EIGRP neighbor relationship, so there's something else going on preventing the connection. What does the output of 'show ip eigrp vrf Green int' show? – cpt_fink Sep 19 '14 at 3:57
  • Added it to question for you. – Rumblebutt Sep 19 '14 at 18:48
  • Is this the hub output, or the spoke? And how many spokes are there now? What is the output of show dmvpn? – cpt_fink Oct 3 '14 at 6:51
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 10 '17 at 15:18
3

Try adding this command to your tunnel interface. Your spokes are receiving routes with the next-hop as the hub router without it.

no ip next-hop-self eigrp 1601
  • It's already added to the tunnel interface via the eigrp named routing configuration. I've tried it both ways. – Rumblebutt Sep 19 '14 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.