5

I have a Cisco WS-C3560G-24PS. We're going to make some changes to it, so I ran the command show archive config diff to make sure everything is fine if we need to revert the changes.

My problem is that when I run that command it gives me the following that is in my running config:

crypto pki certificate chain TP-self-signed-##########
 +certificate self-signed 01 nvram:IOS-Self-Sig#1.cer
crypto pki certificate chain TP-self-signed-##########
 -certificate self-signed 01
  lots and lots of numbers

After checking with my manager, he confirmed that we added some certificates to the switch and I can save the running config. I ran the command copy system:running-config nvram:startup-config and ran the show archive config diff again and it shows the same thing. Cisco isn't my strong suite, so I'm not sure if this is normal behavior with certificates on a Cisco device or not. Is this something I need to worry about?

2
  • Try a simpler command: "write memory" and see if that clears it up. – Ron Trunk Oct 2 '14 at 17:17
  • Yes, I tried that too and it's displaying the same message. I'm assuming this has something to do with Crypto and perhaps is generated on boot up. But I don't know enough about Cisco to know for sure. – Nixphoe Oct 2 '14 at 17:39
2

Use the archive config command to write a new copy of the config to the archive. That should clear up your diffs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.