3

JunOS newbie question here.

I have a Juniper SRX router that I am trying to set up in a very basic mode:

ge-0/0/0 is set to 192.168.140.100 -- I can ping that address from hostA at .140.200 attached to the router

ge-4/0/0 is set to 192.168.144.104 -- I can also ping that address from hostB at .144.200 also attached to router

From JunOS, I can also ping/ssh to hostA and hostB

BUT, I can't access hostA from hostB (these are Centos based. I have created ip routes on them so they know how to acccess each other).

Do I need to create static routes on the router? I have tried that and that doesnt seem to work. Here are my router routes:

admin@JUN01> show route terse

inet.0: 8 destinations, 16 routes (8 active, 0 holddown, 0 hidden) + = Active Route, - = Last Active, * = Both

A Destination P Prf Metric 1 Metric 2 Next hop AS path

  • 192.168.140.100/32 D 0 >ge-0/0/0.0
    L 0 Local
  • 192.168.141.101/32 D 0 >ge-0/0/1.0
    L 0 Local
  • 192.168.142.102/32 D 0 >ge-0/0/2.0
    L 0 Local
  • 192.168.143.103/32 D 0 >ge-0/0/3.0
    L 0 Local
  • 192.168.144.104/32 D 0 >ge-0/0/4.0
    L 0 Local
  • 192.168.145.105/32 D 0 >ge-0/0/5.0
    L 0 Local
  • 192.168.146.106/32 D 0 >ge-0/0/6.0
    L 0 Local
  • 192.168.147.107/32 D 0 >ge-0/0/7.0
    L 0 Local

Thanks a lot -jfs

3

Juniper SRX by default works in a flow mode (it acts like a firewall), so probably you will need to create appropriate security zones, assign interfaces and define policies in order for the traffic to pass through device.

You can also switch the SRX into packet mode, which will make its behavior more like a router.

You can check operational mode using the following command:

mk@SRX210> show security flow status 
Flow forwarding mode:
Inet forwarding mode: flow based
Inet6 forwarding mode: drop
MPLS forwarding mode: drop
ISO forwarding mode: drop
Advanced services data-plane memory mode: Default
Flow trace status
Flow tracing status: off
Flow session distribution
Distribution mode: RR-based

And you can switch into packet mode by issuing following commands:

mk@SRX210# delete security 
mk@SRX210# set security forwarding-options family mpls mode packet-based 
  • Hi, I tried your commands. But that didn't help. The router is still not forwarding. – user2099930 Oct 13 '14 at 1:46
  • Hi, are you trying in flow mode, or packet mode? please post relevant configs - sections "interfaces", "security", "vlans", "forwarding-options" at minimum. – mkurek Oct 13 '14 at 3:33
  • I have re-checked it all, and it is now working. Thanks for yr answer and yr nice help! – user2099930 Oct 13 '14 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.