1

MY QUESTION IS:

  1. Is it possible to use static DHCP leases for same IP addres and two MAC addresses - LAN and WAN - that the host would be able to receive all the time the same IP address (192.168.1.100) regardless of LAN or WAN connection ?

MikroTik - same static DHCP lease with one IP address for LAN and WAN

I have problem with DHCP static leases in MikrtoTik CloudCore 1036. When I use static lease for WAN MAC address everything goes fine and host get IP 192.168.1.100. When I switch from WAN to LAN connection host don't receive IP 192.168.1.100 because there is already static lease for this IP address. I can`t enable second MAC to IP record because there is an information that this address already belongs to the host.

1

If you want to go with static IP addresses then you can specify the dhcp-server by name against each lease. As user3799089 pointed out, the latest RouterOS supports this, you may need to upgrade if the option doesn't exist. I'm running 6.23.

Here's an example from my config:

/ip dhcp-server
add address-pool=lan_pool disabled=no interface=LAN-bridge lease-time=3d name=lan
add address-pool=other_pool disabled=no interface=DMZ-bridge lease-time=3d name=DMZ
/ip dhcp-server lease
add address=192.168.0.254 client-id=1:0:c:29:ef:**:** mac-address=00:0C:29:EF:**:** server=lan
/ip pool
add name=lan_pool ranges=192.168.0.100-192.168.0.199
add address=192.168.1.254 client-id=1:0:c:29:ef:**:** mac-address=00:0C:29:EF:**:** server=DMZ

MAC address has been partially obscured with **.

| improve this answer | |
  • Yes, but I want among all hosts use same IP address forr specified MAC address - always the same no matter host receive signal from cooper or WiFi. – user3799089 Apr 5 '15 at 7:03
1

To be honest I barely understand what you want or trying to accomplish.

But in any case, you can only have one static lease per MAC Address or IP Address.

The only way to have more than one is to disable the current lease and add the new one.

You can then disable/enable whichever lease you need each time.

| improve this answer | |
  • But how to achieve it automatically ? – user3799089 Jul 8 '15 at 13:23
  • I cannot answer that since I do not understand what you are trying to do. – Cha0s Jul 8 '15 at 14:15
0

I just checked here on my RB951 (don't know if you're running routerOS also) and there's no specification of interfaces in IP>DHCP SERVER>LEASES.

The only thing I could see causing the problem is if you have separate DHCP address pool for each interface, even if overlapping. I tested changing ports and the host still gets the same reserved address.

For what I have seen, the only difference from a LAN port and a WAN port in a MikroTik router is the DHCP, in the former it's configured for DHCP server and the latter for DHCP client.

Can you provide configs?

| improve this answer | |
0

Create a bridge and assign WAN and LAN PORT in same bridge. Assign your DHCP to new bridge interface. Start leasing and make static leases. The lease should be the same between interfaces in new Bridge.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.