1

I've configured SIP behind nat, but facing issues with RTP -- i.e I cannot have any voice communication, but signalling is ok.

Please find below config

interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 192.168.1.224 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address X.X.X.X 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
ip nat inside source list 111 interface GigabitEthernet0/1 overload
ip nat inside source static udp 192.168.1.218 5060 interface GigabitEthernet0/1 5060
ip route 0.0.0.0 0.0.0.0 X.X.X.X
ip route 192.168.101.0 255.255.255.0 192.168.1.215
!
access-list 111 permit ip host 192.168.1.215 any
access-list 111 permit ip host 192.168.1.216 any
access-list 111 permit ip host 192.168.1.217 any
access-list 111 permit ip host 192.168.1.218 any
access-list 111 permit ip host 192.168.1.219 any
access-list 111 permit ip host 192.168.1.220 any

192.168.1.218 is my Sip Server
192.168.1.220 is Media gateway
192.168.101.0 is Voice Network

  • I never done anything like what you are trying to do there but why you want to put the SIP proxy server behind a NAT device? For security? When you say "no voice communication", you mean no voice communication between end-points, right? If possible, try to do 1-to-1 nat for the SIP and media gateway. – m1xed0s Jan 6 '15 at 13:16
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 10 '17 at 22:51
2
  1. Your access-list doesn't allow NAT for 192.168.101.0/24, so they cannot talk to anything on the Internet. (they should be talking to your proxy, but might not.)
  2. You have no NAT mapping(s) for RTP traffic, so unsolicited traffic from the internet won't make it past the router.

(As you can see, running SIP behind NAT is an enormous pain in the a**.)

  • Can u provide me with working Sip behind Nat configuration with RTP – Mohammed KHan Nov 7 '14 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.