1

This is a small site in the 3rd and 4th floor of the building. We deployed 3 AP's in the Third floor and 2 AP's in the fourth floor. Additionally a new AP is configured and yet to set in the fourth floor. There is no problem in the 4the floor but in the 3rd floor.

Note: Site survey is not taken by the previous engineer who setup this.

AP1 and AP3 are working fine but the AP2 is having problem. Users near the AP2 having limited connectivity problem though they are close to the AP. So thought there might be some interference and disconnected the AP1. Found it is working quite well for all the users. Though sometimes users are thrown out of the network. Still some users saying the fourth floor AP is connecting and found working fine.

Most users are using MAC. 802.11b/g clients.

Configured only single SSID "KPH-3 SAL"

TAC support suggested this on the radio interface 0

#speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0

This is my configuration

hostname KPH-3-SAL-AP2
!
!
logging rate-limit console 9
enable secret 5 <removed>
!
no aaa new-model
no ip source-route
no ip cef
!
!
!
!
dot11 syslog
dot11 activity-timeout unknown default 25000
!
dot11 ssid KPH-3 SAL
   vlan 10
   authentication open
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 7 <removed>
!
!
!
!
!
username CISCO password 7 <removed>
!
!
bridge irb
!
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 10 mode ciphers aes-ccm
 !
 ssid KPH-3 SAL
 !
 antenna gain 0
 stbc
 beamform ofdm
 mbssid
 speed  basic-1.0 basic-2.0 basic-5.5 basic-11.0 basic-6.0 basic-9.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 packet retries 128 drop-packet
 station-role root
 no dot11 extension aironet
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.10
 encapsulation dot1Q 10
 no ip route-cache
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface Dot11Radio1
 no ip address
 !
 encryption vlan 10 mode ciphers aes-ccm
 !
 ssid KPH-3 SAL
 !
 antenna gain 0
 peakdetect
 no dfs band block
 stbc
 beamform ofdm
 mbssid
 speed  basic-12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
 packet retries 128 drop-packet
 channel dfs
 station-role root
 no dot11 extension aironet
!
interface Dot11Radio1.1
 encapsulation dot1Q 1 native
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio1.10
 encapsulation dot1Q 10
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface GigabitEthernet0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0.1
 encapsulation dot1Q 1 native
 bridge-group 1
 bridge-group 1 spanning-disabled
 no bridge-group 1 source-learning
!
interface GigabitEthernet0.10
 encapsulation dot1Q 10
 bridge-group 10
 bridge-group 10 spanning-disabled
 no bridge-group 10 source-learning
!
interface BVI1
 mac-address 18e7.28f7.8468
 ip address 192.168.1.43 255.255.255.0
 ipv6 address dhcp
 ipv6 address autoconfig
 ipv6 enable
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
 password 7 <removed>
 login
line vty 0 4
 password 7 <removed>
 login
 length 0
 transport input all
line vty 5 15
 password 7 <removed>
 login
 transport input all
!
end

Kindly suggest me some ideas to fix this.

2
  • Can you monitor with wireshark like tools if someone is sending a deauthentication command to all hosts connected in your network. This might be one of the many cause. I say again "might be".
    – Damon
    Nov 24 '14 at 13:14
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 10 '17 at 23:22
3

I have to disagree with TAC on this one. Running those low speeds is really not a good idea. I wouldn't run anything lower than 12 unless you absolutely need 11b.

If you have interference, the only way you're going to find it is with some sort of sniffer or spectrum analyzer. Maybe you can borrow one?

Try turning off your WLAN and see what other wifi signals you pick up. You might look for microwave ovens in the vicinity. You can also try changing channels to see if that helps (choose from 1, 6 or 11).

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.