4

I need to get to a point where my routers ask me for a user and password after I've entered the "enable" command. like this:

Config example

Can anyone help with this?

Thanks!

  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 8 '17 at 2:51
3

You can't do that, but you can configure the router so it prompts for name/password at login, and based on the user's privilege, they will be in enable mode or not. So instead of a two-step login, they login once and are put in the proper mode.

username farouk password foo 
username jong-mee password bar privilege 15

aaa new-model
aaa authentication login default local
aaa authorization enable default local

When jong-mee logs in, she gets prompted for her password, and immediately goes into enable mode. But when Farouk logs in, he is only in user mode.

Make the enable secret long and complicated so it can't be guessed. You won't have to use it anymore.

| improve this answer | |
  • Thanks for the answer, I will try the suggested config, although I do know that it is possible to be prompted for the Username and password after the "enable" command, just like it is on the screenshot I posted. This was from a customer of mine and I'm trying to replicate this since they are...not in a sharing mood :) – Harnik Nov 26 '14 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.