6

I am trying to debug STP on a C7613 but I have logging issues. IOS version 15.2(4)S2 The Route Switch Processor is RSP720-3CXL-GE

I'm running every debug commands for Spanning-Tree but nothing gets shown either on the console or in the logs.

Here are my debug commands :

debug spanning-tree events
debug spanning-tree bpdu receive

I know that RSTP is running on my switch, as well as my ports are receiving BPDUs all the time. I should see traffic with this debug.

Here is the logging config :

logging buffered 10000000000
logging monitor debugging
logging alarm informational
logging trap debugging
logging facility local2
logging host 10.162.33.69
logging console

Why is it that I cannot see anything in the logs from this debug ? Also, I tried with a CDP debug and all the debug logs were seen in the logs buffer. This seems like a STP issue.

Thanks for the help

  • Sorry for daft question, but there's another switch in the picture, right? If not, then you'll never receive pbdus and you won't see any events because nothing changes as far as STP is concerned once it does it's first calculations on startup. EDIT: You've said you know you're receiving BPDUs - can you elaborate on how? – A J Rossington Nov 27 '14 at 16:44
  • using the "show spanning-tree interface gx/x detail", one can see if the port is receiving/sending BPDUs. As far as I can tell all my ports are receiving BPDUs. There are other switches in the picture, and the STP Topology is fully active. – Jeremy G. Nov 27 '14 at 18:26
  • What are the line cards you are running STP on? You said you can see debug messages for CDP, is this via a TTY and you are using term mon or are you via local console port? – jwbensley May 6 '15 at 20:59
  • Have you tried to replace logging console for logging console debug, also have you looked on your switch processor? remote login switch then show logging ? – jwbensley Feb 5 '16 at 14:54
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 10 '17 at 3:03
2

The RSP720 in the router has two processing engines. The route processor (RP) and the switch processor (SP).

When you log-in to the console/telnet/ssh on a 7600 that's running IOS on both the RP and the SP (Native mode), you log-in to the RP by default. The spanning-tree function is however performed by the SP.

After logging into the box try:

term mon
remote command switch debug spanning-tree bpdu receive

You should see some output. The debug must also be turned off using the remote command switch command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.