4

I am currently using Wireshark version 1.12.2. When I searched the internet I found this result alt text

But, this option is not available in my version. I could see only the "Relative sequence numbers" check box. There is no option to enable/disable "Window scaling" feature. Where can I find this in Wireshark v1.12.2 ? Thanks in advance.

5

So all you need to do is: Right Click one of the TCP segments => Protocol Preferences => uncheck Relative Sequence Numbers.

Relative-Sequence-Numbers

FYI: Ignore the filters, I just did that to make it more aesthetically pleasing. They have nothing to do with the option selected.

EDIT

So to address your comment:

In the older version of Ethereal it has the option to disable relative sequence numbers and window scaling. When the window scaling option is enabled in the older version you first mentioned (Ethereal aka old school Wireshark), it simply calculates the current window size against the current window scaling factor to give you a total. When it's disabled, it only displays the current window size without the scaling factor taken into account.

Window-Scaling

The picture above is a snippet from the new version of Wireshark sniffing a TCP segment. Here's how it correlates to the older version.

Window Size value This is the value present when window scaling is disabled in the older version. Calculated Window size This is the value present when window scaling is enabled in the older version.

The major difference being is that the newer version contains both values and not just one or the other, so disabling the window scaling option isn't necessary.

5
  • nice answer jhead – John Jensen Nov 30 '14 at 5:21
  • @jordan Isn't that option only for enabling/disabling relative seq number ? I want to disable window scaling. – Ezio Nov 30 '14 at 5:47
  • @Ezio I edited my answer to give you some more context, hope it helps. – Jordan Head Nov 30 '14 at 9:06
  • @jordan Understood. I tried myself with a older version (1.4.7) and this version, and observed the results.. Thank you very much !! – Ezio Nov 30 '14 at 19:54
  • @Ezio No worries, happy to help. – Jordan Head Nov 30 '14 at 19:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.