2

This has exhausted every resource I've found and nothing explains why enabling any vLAN besides the management vLAN automatically shutdowns the management vLAN rendering their switch ports useless for IP traffic.

It's a portable CCNA lab and following the exercises in Cisco's Exploration 3 and 4... creating a new management vLAN or using the default mgmt vLAN1 still Administratively shutdowns the currently running vLAN after "no shut" a different vLAN.

Switches aren't constrained to just one running vLAN, but why is my config instantly shutting down the other singular operating vLAN the instant I "no shut" a different vLAN.

Appended an abridged running config and thoroughly exhausted the troubleshooting methods. More suggestions for additional troubleshooting are well meant...

I'm in need of some skilled peek of my flawed config instead of more suggestions cause I've exhaustively troublehshooted and switched cables to the infinite.

By now, I'm leaning towards some insidious Cisco limitation in a workgroup switch but the 2940 has seemingly executed every function w/o objection.

Thanks in advance

====RUNNING CONFIG (ABRIDGED FOR CLARITY)

spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 99
 switchport mode dynamic auto
 mdix auto
 spanning-tree portfast
!
interface FastEthernet0/2
 switchport access vlan 99
 switchport mode dynamic auto
 mdix auto
!
interface FastEthernet0/3
 switchport access vlan 30
 mdix auto
!
interface FastEthernet0/4
 switchport access vlan 20
 switchport trunk native vlan 20
 switchport mode dynamic auto
 mdix auto

===SNIP===

interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan12
 no ip address
 no ip route-cache
!
interface Vlan20
 ip address 172.16.20.20 255.255.255.0
 no ip route-cache
 shutdown
!
interface Vlan99
 ip address 172.16.1.3 255.255.255.0
 no ip route-cache

Enabling VLAN interface:

square(config-if-range)#inte vlan 99
square(config-if)#no shut
square(config-if)#
00:58:52: %LINK-3-UPDOWN: Interface Vlan99, changed state to up
00:58:52: %LINK-5-CHANGED: Interface Vlan20, changed state to administratively down
00:58:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up

do sh vlan brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Gi0/1
10   FacultyStaff                     active
20   Students                         active    Fa0/4
30   Guest                            active    Fa0/3
99   ManagementNative                 active    Fa0/1, Fa0/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
8

What you are actually referring to is the Switch Virtual Interface (SVI) and this assigns a L3 interface to a VLAN.

VLANs are L2 and do not require an SVI to function. This switch can support up to 128 VLANs.

The 2940 is a L2 switch. The SVI is only for management, and the switch does not have any L3 routing capabilities. As such, it only supports one active SVI at any time, as does the 2950 platform it is based upon.

For a quick reference as to it's capabilities, you can check the datasheet on Cisco's website.

2
  • That's helpful, trouble you for the last / can you suggest a better model than the 2940 to use for the CCNA track since the Exp 3/4 assumed I was back on the community college campus and I prefer phys hardware. Thanks again for clarifying my original distress call and so quickly. – CommodoreDamage Dec 2 '14 at 1:56
  • 1
    Product recommendations are typically off topic here, but if you are looking for the lowest cost L3 switches, look at something like the 3550, 3560, or 3750 line. Most hardware based labs will use these or their newer variants (which can also often run newer versions of code but will cost more. – YLearn Dec 2 '14 at 2:01
0

This behavior is by design.

See:

https://supportforums.cisco.com/discussion/9992351/creating-multiple-vlans-ip-addresses-2940-8tf

1
  • 1
    Thanks for that link, (its embarrasing my same problem was solved 8 YEARS AGO) but you're response helped tremendously and I can start regrowing my hair – CommodoreDamage Dec 2 '14 at 2:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.