5

I have a Cisco 2621XM connected straight to my ISP modem. I have a computer on the second interface of the router.

Topology:

ISP -> Modem -> Cisco Router -> Computer

When I run a speedtest on my computer I get 30/10. When I connect my computer straight to my modem I get 100/10. I also have another Cisco Router, 871. Same exact results, I get 30/10 when I connect my computer to it.

I'm starting to think that it's a default setting that comes baked into the router? Here's my config:

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 <REMOVED>
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
ip cef
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.4.4.1 10.4.4.100
!
ip dhcp pool ALL_ACCESS
   network 10.4.4.0 255.255.255.0
   dns-server 8.8.8.8 8.8.4.4
   default-router 10.4.4.1
!
interface FastEthernet0/0
 ip address 10.4.4.1 255.255.255.0
 ip nat inside
 speed 100
 full-duplex
!
interface Serial0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
ip classless
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 10.4.4.0 0.0.0.255
!
control-plane
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
line vty 5 181
 login
!
end

Output from show interface:

Router#sh interfaces FastEthernet0/1
FastEthernet0/1 is up, line protocol is up
  Hardware is AmdFE, address is 000e.3836.ff41 (bia 000e.3836.ff41)
  Internet address is xxx.xxx.xxx.xxx/xx
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 1/75/128247/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 51000 bits/sec, 41 packets/sec
  5 minute output rate 4000 bits/sec, 6 packets/sec
     16778657 packets input, 2855708480 bytes
     Received 5967982 broadcasts, 0 runts, 0 giants, 0 throttles
     69379 input errors, 0 CRC, 0 frame, 15274 overrun, 54105 ignored
     0 watchdog
     0 input packets with dribble condition detected
     3231581 packets output, 590804149 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     484 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

sh interfaces FastEthernet0/1 status - Doesn't output anything

1
  • If you could add the output of show interfaces Fa0/0 as well, we should also be able to determine if you are experiencing performance loss from a duplex mismatch as well.
    – YLearn
    Dec 18, 2014 at 17:44

4 Answers 4

8

Neither of the routers you are referencing will ever be able to run at line rate. While the 2621XM is a better "class" of device, it is much older, so the performance is actually similar.

While dated, this document contains details for both routers you mention.

The "overrun" and "ignored" errors in your interface output indicate you are trying to pass more data through the device than it can handle.

3
  • There's also a likely duplex mismatch on the inside interface -- we don't know what's attaching to that port. But yes, bottom line, those are not line rate platforms. (esp. with NAT)
    – Ricky
    Dec 17, 2014 at 21:04
  • He didn't provide any output for FastEthernet0/**0** -- which is the force config'd interface. But yes, the 0/1 stats clearly show it cannot keep up with the rate from the modem.
    – Ricky
    Dec 18, 2014 at 0:31
  • Somehow when I read the last line of the OP's question about no output, it stuck in my mind that the output provided was from Fa0/0. On re-reading, clearly I was wrong.
    – YLearn
    Dec 18, 2014 at 6:42
6

You have input errors on that interface.

     69379 input errors, 0 CRC, 0 frame, 15274 overrun, 54105 ignored

Check speed/duplex on both sides, or just set to auto negotiate on both sides

2
  • 2
    The are not the types of errors one would expect with a duplex mismatch. With a duplex mismatch, you would see runts/CRC on input or collisions/late collision on output.
    – YLearn
    Dec 17, 2014 at 19:44
  • True, but it's always worth verifying and removing speed/duplex mismatch from the possibilities. Dunno about you, but I've had plenty of supposedly simple stuff not work (or worse, not fail) as one would expect.
    – Smithers
    Dec 18, 2014 at 18:08
0

Can you post a show interfaces of the WAN connection?

sh interfaces FastEthernet0/1
sh interfaces FastEthernet0/1 status

Maybe the portspeed is not what is should be.

This guy is having the same problem, could be the CPU that is to slow.

Additional info: https://supportforums.cisco.com/discussion/11377266/cpu-utilization-hitting-100-cisco-2621xm

0
interface FastEthernet0/0
 no ip address 
 ip nat outside
 speed 100
 full-duplex
!
interface Serial0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address 10.4.4.1 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
1
  • 1
    You could greatly improve your answer by explaining it. Please edit your answer to add an explanation and context.
    – Ron Maupin
    Aug 8, 2018 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.