9

We have a ME3400 that we want to enable CDP on but there is no cdp option. Why is it not available?

switch(config)#int gi0/1
switch(config-if)#cdp ?
% Unrecognized command

CDP is enabled globally.

switch#show cdp
Global CDP information:
        Sending CDP packets every 60 seconds
        Sending a holdtime value of 180 seconds
        Sending CDPv2 advertisements is enabled

Here is the running config of that interface.

interface GigabitEthernet0/1
 switchport trunk allowed vlan 101-108,110,112-115,119,170,192,211,254-262,268
 switchport trunk allowed vlan add 269,271,508-512,701,888
 switchport mode trunk
 load-interval 30
 udld port
11

CDP is not allowed on ports running in UNI mode. If you use:

show port-type

You should see which mode the port is running in. You need to use ENI or NNI to support CDP on the interface.

|improve this answer|||||
  • 3
    And also needs to be explicitly allowed on an ENI port, while an NNI has CDP enabled by default – mellowd Jun 1 '13 at 5:28
6

I remember dealing with this exact same issue a long while ago.

The reason why by default the ME3400 or any of the ME series don't have CDP enabled is due to the fact they're supposed to be deployed at the PE/CE. A service provider would not want to leak its CDP information to the customer.

interface GigabitEthernet0/3 port-type nni

Depending on the interface - the default port-type is UNI (which is most of the interfaces)

Take a look here for further description and information http://www.cisco.com/en/US/docs/switches/metro/me3400/software/release/12.2_25_seg_seg1/configuration/guide/swint.html#wp1026705

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.