8

I've been having problems with Cisco Prime 1.3 (and other versions) re-sizing maps once you've put them into the map view. This happens for buildings and floors alike. On the cisco documentation it says this:

Step 1 Save the map in .PNG, .JPG, .JPEG, or .GIF format. Note The map can be of any size because Prime Infrastructure automatically resizes the map to fit its working areas.

From my experience, these maps are re-sized based on the width of the work area (i'd say around 800 pixels). The problem I'm having is that some maps are very thin; one is 200 x 800 pixels, which means Prime is re-sizing this map to be 800 x 3200! It only has a few APs on this map, so scrolling the map is just plain annoying.

Does anybody know a way to stop Prime from re-sizing maps in this way?

Also, I cannot rotate the building, because the maps are based off a campus map, which requires the buildings to be facing the right direction.

  • Did you try disabling the Maintain Aspect Ratio to prevent the length and width distortion when the map is first loaded and resized? – generalnetworkerror Jun 4 '13 at 3:05
  • The aspect ratio keeps the length and width in line with each other, it doesnt stop it being resized. I've tried this ticked and unticked. – Artanix Jun 4 '13 at 6:44
  • I've raised this with Cisco, waiting to hear back if there is a workaround – Artanix Jun 14 '13 at 11:04
  • We looking forward to your update here. – generalnetworkerror Jun 14 '13 at 21:01
5
+50

You could try disabling the Next Generation Maps in Monitor > Site Maps Properties to see if this makes a difference. It did on my map test. There are performance reasons for not doing this.

Site Maps Prop

You might also be able to manually resize the image. Go into Edit Floor, then on the bottom-left, you'll see your 200x800 map. Use the CTRL-click to drag the blue edges to your desired size.

Prime map floor editor

  • On that menu I have no option to turn off dynamic maps? Only units of measurement, wall usage, floor start index, etc. re-sizing on edit floor just means the scale is changed and the map is extended out to the work space again. – Artanix Jun 6 '13 at 10:47
  • Is that option missing from you 1.3 Prime or just older versions? – generalnetworkerror Jun 6 '13 at 18:33
  • I added Site Maps Properties screencap to the answer. This is from v1.3 (1.3.0.20). – generalnetworkerror Jun 6 '13 at 22:54
  • Looks like I've been mistaken, I thought NCS at this site was on 1.3, turns out its on 1.1. Just to add here, it doesn't seem possible on 1.1, but I'll take this as the answer for 1.3. – Artanix Jun 7 '13 at 7:36
1

CAVEAT: I have never used Cisco Prime. However, here is a different idea:

  1. Take the 200x 800 map out of Cisco Prime.
  2. Add some white space around the outside in MS Paint.
  3. Make the new map 800x 800.
  4. Place it back in Cisco Prime.

Could that be an option?

  • Not really an option. Because the campus map has alot of buildings around it. If I make an 800x800 map, the building would then need to be a square to allow the dimensions of that map to fit within it. Which then causes overlap issues. I guess the overlap would be ok, as theres only white space, but I don't think the guys I install this for would be happy with the results. – Artanix Jun 6 '13 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.