23

I was doing some cisco exercises on configuring a vtp server and client, something I can't figure out is :

  • I setup a vtp server, added my VLAN's

  • I then took another switch that was attached to this vtp server and
    set it to client

  • Now my VTP client didn't get the vlans configured on the vtp server, however when I added another vlan on my server, suddenly they were all there

Is there a way to push the configs, like a force update command ?

  • 3
    As an aside, be extremely careful with VTP and new switches. It is extremely easy to accidentally blow away your VTP database, so be sure that you set a VTP domain that is not the default so a switch that happens to have a high revision number does not take over and replace your huge VTP tree with one of its own. – Aaron May 8 '13 at 18:45
  • Is your trunk working correctly? – user2382 Aug 23 '13 at 7:19
23

You can't manually force updates because VTP configs are pushed based on the highest current VLAN database revision number. Normally, after every change to your VTP config the configuration revision number should be incremented. The only way to force update this is by actually doing a VTP database change.

| improve this answer | |
  • 2
    If you have a unique situation where your client switch has a higher version # than the server, you either have to increase the version on the server (through multiple changes in the DB), or reset the client's version count by switching the VTP to another value, and then back to match the existing server, which will click the client's version to 0, making it request the newest DB from the server. – nicotine May 13 '13 at 18:55
13

If VTP is not updating the VLANs correctly, check to make sure the MD5 digest on all VTP domain switches is the same. The MD5 digest is calculated using the revision number, domain name, and password to make sure the information in the VTP update can be trusted. I've seen issues where switches configured with the same domain and password, but the MD5 digest is not aligned until I update the VLAN database on the VTP server. This is typically caused by the local revision number being different between the switches. Making a VLAN change on the VTP server will send out a VTP update to all domain switches with the newest revision number so that the MD5 digests should align properly.

You can see the VTP md5 digest with a "show vtp status" command on each switch:

SW1(config)#do sh vtp statu
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 17
VTP Operating Mode              : Server
VTP Domain Name                 : CISCO
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x09 0xF0 0xD7 0x82 0xB7 0x08 0x82 0xAA 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 155.1.7.7 on interface Vl7 (lowest numbered VLAN interface found)


SW2(config)#do sh vtp statu
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 17
VTP Operating Mode              : Client
VTP Domain Name                 : CISCO
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x09 0xF0 0xD7 0x82 0xB7 0x08 0x82 0xAA 
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
| improve this answer | |
9

Updates to VTP are only sent out when there is an increment to the VTP revision number. The only way to 'force' an update is to create an erroneous Vlan and then delete it. This will accomplish a 'force update' and send the change out to the rest of your clients.

| improve this answer | |
  • 7
    Modifying the name of a VLAN is usually less disruptive (as messing about with new VLANs also creates a new STP instance and might cause unnecessary load in your switched domain). – noaru May 7 '13 at 22:44
5

An alternate way to force an update is to change the switch that needs the update to Transparent mode which resets the counter to Zero and then put it back into client mode or server mode. This will force the switch to jump from revision 0 to whatever the current highest revision is and the database will be overwritten.

Hope this helps.

| improve this answer | |
  • @ Jeff Vincent After making sure my VTP server had the highest revision number, and that all the devices had the same VTP password, domain name, and version, I was still having trouble syncing VLAN data on all my network devices. Putting the VTP server into transparent mode and back did the trick! There was a 1 or 2 minute turn around where my putty window froze and I was kicked out of my remote connection, though. I'm guessing the amount of changes it needed to push ate up bandwidth or processing power, but it's all up and running now! Thanks so much for the help!!! – John Molle Jan 11 '18 at 17:35
1

Change the domain of the client and rechange it back to the same domain this should reset the VTP counter and now the client will get the VLANS from the VLAN server

| improve this answer | |
  • Generally answers are more than a single sentence. You could break your answer down to steps, indicating whether the switches should be connected or not as VTP domains are changed, for example. – generalnetworkerror Aug 22 '13 at 8:12
  • @generalnetworkerror, while it is true that one-sentence answers are not preferable; it happens that this solution has sufficient detail in one sentence. It is acceptable – Mike Pennington Aug 22 '13 at 8:51
  • @MikePennington, the answer has sufficient detail for knowledgeable network engineers, but lacking SE quality: meta.stackexchange.com/questions/7656/… – generalnetworkerror Aug 22 '13 at 9:20
  • 3
    @generalnetworkerror, you seem to be confusing the definitions of "good" and "acceptable". Please ask a question in meta for further debate. – Mike Pennington Aug 22 '13 at 9:31
1

While most people get the vtp config setup they sometimes forget to trunk the interface. When all your vtp stuff looks right (but config rev not incrementing/updating) then it's probably a trunking issue on the int itself - try switchport trunk encap dot1q/isl then switchport mode trunk - should do the trick - kerry_13 had this exactly right, that answer should be at the top for all the times i've seen new guys do it.

| improve this answer | |
0

A vtp advertisement is sent only when their is a change in the revision number. How we can change the revision number? Pretty easy.. create and delete a dummy vlan. We cant force a client to pull the update from the server.

| improve this answer | |
  • 1
    This is almost a duplicate of Mark Wei's answer and adds nothing. – YLearn May 21 '13 at 12:53
0

I think you should check whether you configure the client switch port with mode trunk or not, it update automatically, right after you put the right domain name and password.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.