6

This is to support a user who has the requirement of simulating specific speeds for download/upload. We have configured a limit using service-policy that as successfully limiting upload speed (ingress on the interface) but we (more importantly) need to limit download speed (egress on the interface). I know of using srr-queue but we need specific speeds (such as 512KB). Been banging away at this for a few days now and can't find a working method. I pursued shaping via:

class-map match-any CLASS_EgressLimit_512KB
  match access-group name ACL_RateLimit_512KB
policy-map POLICY_EgressLimit_512KB
  class CLASS_EgressLimit_512KB
    shape average 512000
interface gi0/6
  service-policy output POLICY_EgressLimit_512KB

but shaping doesn't seem to be supported in this context on our switch

(WS-C2960G-8TC-L 15.0(2)SE4 C2960-LANBASEK9-M)

Any help is sincerely appreciated!

  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 7 '17 at 19:14
3
mls qos aggregate-policer ltusa-5mbps-in 5000000 625000 exceed-action drop
mls qos aggregate-policer ltusa-5mbps-out 5000000 625000 exceed-action drop
mls qos min-reserve 5 170
mls qos min-reserve 6 85
mls qos min-reserve 7 51
mls qos min-reserve 8 34
mls qos
...
class-map match-all cm-ltusa
 match ip dscp default 
!
policy-map pm-ltusa-out
 class cm-ltusa
    police aggregate ltusa-5mbps-out
policy-map pm-ltusa-in
 class cm-ltusa
    police aggregate ltusa-5mbps-in
...
interface FastEthernet0/xxx
 switchport access vlan 4000
 switchport mode access
 fair-queue
 service-policy input pm-ltusa-in
 service-policy output pm-ltusa-out

As far as I recall, that worked on my 3550. (It's not in service anymore.) There's more than one interface in vlan 4000; all have the same configuration. mls qos is the Magic™ to make shaping work on a switch.

1

The configuration you're trying to use is based on router capabilities, not switch capabilities. While it's true 2960 can do shaping, it's configured in a different way and works in a slightly different way.

Please take a look here to read about the idea, and then when you have configuration get back with any other, specific questions:

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960/software/release/12-2_55_se/configuration/guide/scg_2960/swqos.html#wp1200681

One example of configuring sub-rate shaping on interface is proposed here:

http://www.techrepublic.com/blog/data-center/limit-bandwidth-on-a-cisco-catalyst-switch-port/

  • I've pursued your techreplublic link (which i've reviewed already) and using srr-queue will only make for a 10% reduction on a 1GB port (making for 100MB). Rate-limit doesn't seem to be a supported command for either the VLAN or switch port interface, so I'm not sure how that would be useful here. In the Cisco link here is what I take away from it: srr-queue bandwidth shape srr-queue bandwidth share Both may be relevant to resolving my requirement but I'm not sure the relationship between configuring these commands and bandwidth, esp. with the multiple weights for egress queues.TY – lasersauce Jan 8 '15 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.