1

I have an external DSL link on a ground floor of my building that needs to be sent up to the second floor. Now im sure it would be easy to just run a cable however thats not an option. However, i do have cisco 3750 switches on each floor and they are all tied in floor by floor.

My question is how do I create a vlan and trunk this DSL link through my switches to the second floor without it broadcasting through my network other than on a port specified on my second floor?

EDIT:

I tried to user Panther Modern's answer, but I still can't get it to work.

Here is what my port configuration looks like floor to floor for what I am trying to do. Please let me know if you see anything that could be stopping the traffic flow.

GROUND FL SW

interface GigabitEthernet1/0/45
 description DSL UPLINK
 switchport access vlan 93
 switchport mode access

interface GigabitEthernet1/0/49
 description Trunk to 1st Fl
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,70,93

interface Vlan93
 ip address 10.244.193.254 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp

1ST FL SW

interface GigabitEthernet3/7
 description Trunk to Ground Fl
 no ip address
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,70,85,93
 switchport mode trunk

interface GigabitEthernet3/1
 description Trunk to 2nd Fl
 no ip address
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,51,72,74,81-83,85,93,172,1080
 switchport mode trunk

2ND FL SW

interface GigabitEthernet1/0/49
 description Trunk to 1st Fl
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,51,74,81-83,85,93,172,193,600
 switchport mode trunk

 interface GigabitEthernet2/0/37
 description DSL LINK
 switchport access vlan 93
 switchport mode access
2
  • 1
    Your question is phrased poorly. DSL cannot be transported by ethernet. The ethernet side of the DSL modem/router is just like any other network -- setup a VLAN to bring this ethernet segment everywhere it's needed.
    – Ricky
    Jan 9, 2015 at 0:14
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 11, 2017 at 3:18

2 Answers 2

3

This should work fine, as long as the VLAN you're attaching the DSL connection to is extended across your switches.

ARP will take care of the rest, as your clients who need to send any data to the default gateway of the DSL connection will address their frames to the MAC of the DSL modem.

               Gi1/0/1 +----------+ Gi1/0/11            Gi1/0/2 +----------+
DSL--------------------| sw-1stFl |-----------------------------| sw-2ndFl |
192.168.0.1/24         +----------+            dot1q            +----------+
                                                                      | Gi1/0/5
                                                                      | vlan 900 access
                                                                      |
                                                                  Client2-1
                                                                  192.168.0.50/24

If you want to relegate it to a network of its own:

1: Create a new VLAN: 
   vlan 900
     name DSL-EGRESS

2: Create VLAN SVI on your Core Switch: interface vlan 900 ip address [IP] [MASK]

3: Assign membership: 
   interface 1/0/1
     description DSL-MODEM
     switchport access vlan 900

4: Obviously, also your clients who wish to send data to the internet thru the DSL modem will need the DSL modem's internal IP as their default gateway, etc, etc, basic networking stuff. Detailed configs are included below.

EDIT: Configs below provided by Mike Pennington in later edit.


This example configuration makes some assumptions about what IP addresses are assigned.

Configuration for sw-1stFl:

hostname sw-1stFl
vtp mode transparent
!
vlan 900
 name DSL_modem
!
interface Gi1/0/1
 descr [To DSL modem]
 switchport mode access
 switchport access vlan 900
!
interface Gi1/0/11
 description [To sw-2ndFl:Gi1/0/2]
 switchport trunk encapsulation dot1q
 switchport mode trunk
!

interface Vlan900 no shutdown ip address 192.168.0.254 255.255.255.0 no ip proxy-arp no ip redirects no ip unreachables

Configuration for sw-2ndFl:

hostname sw-2ndFl
vtp mode transparent
!
vlan 900
 name DSL_modem
!
interface Gi1/0/2
 description [To sw-1stFl:Gi1/0/11]
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Gi1/0/5
 description [Client2-1]
 switchport mode access
 switchport access vlan 900
2
  • 1
    I took the liberty of adding a configuration to make the answer simpler to use, but I'm not sure you actually need the SVI. It might be confusing the OP into thinking that the address on the SVI should be the default gw. Jan 9, 2015 at 11:14
  • 1
    Like Mike says... please don't confuse the L2 and L3 parts of a vlan. People have a hard enough time understanding the difference, and suggestions like (2) just propagate the myth.
    – cpt_fink
    Jan 12, 2015 at 6:59
0

This doesn't work since the DSL signal is not ethernet, the switches can't transport it.

1
  • Well in truth, it is an ethernet signal from the box. I am just looking to have the ethernet portion of the dsl box give out dhcp on a different floor.
    – Louis
    Jan 8, 2015 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.