2

How to stop a connected network (gig2/1) from being advertised in eigrp? I was thinking to use passive interface but the connected subnet would still be advertised because of "network 10.0.0.0" under eigrp, am I right? Below is the configuration. Thanks a lot.

!
int gig2/1
no switchport
ip address 10.80.1.12 255.255.252.0
!
router eigrp 1
 network 10.0.0.0
!
1
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Commented Aug 11, 2017 at 3:17

2 Answers 2

6

You sound like you are looking for distribute-list. Have a look here for the command reference http://www.cisco.com/c/en/us/td/docs/ios/12_2/iproute/command/reference/fiprrp_r/1rfeigrp.html#wp1030208

Here is what you want, i think (not tested):

access-list 1 deny 10.80.1.12
access-list 1 permit any
router eigrp 1
  network 10.0.0.0
  distribute-list 1 out

(Note a similar method can stop external routes from being learnt, using distribute-list number in)

2
  • This is one of the nice things about EIGRP, you can use a distribute-list with an ACL or a prefix-list to control route announcement.
    – cpt_fink
    Commented Jan 12, 2015 at 3:17
  • If one of the suggestions worked please mark it as answered so people know you don't need further help. If you need more help let us know. Commented Jan 13, 2015 at 0:44
5

Create network statements with subnet masks for each interface you do want to advertise and exclude the interface you don't want to advertise.

For example, if you have

int gi 1/1
ip address 10.1.1.1 255.255.255.0
!
int gi 1/2
ip address 10.1.2.1 255.255.255.0
!
int gi 1/3 
ip address 10.1.3.1 255.255.255.0

if you don't want to advertise 10.1.2.0

router eigrp 1
network 10.1.1.0 255.255.255.0
network 10.1.3.0 255.255.255.0

10.1.2.0 won't be advertised in eigrp

2
  • that is definitely a solution if the number of networks you are advertising is small. If you are excluding a single small subnet from a large one, one class C from a class A for example, is an acl not better? Commented Jan 11, 2015 at 15:33
  • @AcyclicTau Since the question referred to connected networks, I assumed the number would be relatively small. But if you were excluding a single route from a large update, using a distribute list would be a good idea.
    – Ron Trunk
    Commented Jan 12, 2015 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.