0

I tried to configure simple topology using switch layer 3, but it doesn't work and I don't have an idea what is wrong.

enter image description here

When I ping from 192.168.1.2 a computer 192.168.2.3 , a ICMP packet stops at Multilayer Switch. When I remove Switch2, everything works, but my goal is to create multiple switches L2 and each one having link to multilayer switch.

Edit : There was a mistake on label next to multilayer switch VLAN 10 - 192.168.1.1 VLAN 20 - 192.168.2.1

5
  • We'll need to see the config of both switches.
    – dk1
    Jan 24 '15 at 16:35
  • there is no other configuration. On SW2 I created VLAN 10 and VLAN 20. Next, I assigned VLAN 10 to porst fa0/0 and fa0/1 and VLAN 20 on fa0/2 and fa0/3. On fa0/4 I created trunk with allowed VLAN 10-20. On multilayer switch I assigned IP to VLAN 10 and 20. Hosts on VLAN 10 have default gateway 192.168.1.1 and hosts on VLAN 20 have default gateway 192.168.2.1
    – Panyw
    Jan 24 '15 at 16:39
  • 2
    Did you enable "ip routing" on the 3560?
    – RedShift
    Jan 24 '15 at 17:35
  • @RedShift Can you post this as an answer? That appears to have solved the problem.
    – Ryan Foley
    Jan 24 '15 at 19:13
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 11 '17 at 3:31
2

This is a common issue with a simple fix.

config terminal
ip routing
end
copy run start
(You don't want to lose your configuration change and have to fix it again after a reboot.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.