1

We are trying to form the ether channel between cisco WS-C3560V2-48PS model switch with DELL server but ether channel is not established between them. Dell server has 4 NIC and its connected with 3560V2 switch 4 interface and try to bundle into single port channel.

Below i have mentioned the switch config:

!
interface Port-channel1
 switchport access vlan 21
 switchport mode access
end
!
interface FastEthernet0/5
 switchport access vlan 21
 switchport mode access
 channel-group 1 mode active
end
!
!
interface FastEthernet0/6
 switchport access vlan 21
 switchport mode access
 channel-group 1 mode active
end
!
interface FastEthernet0/7
 switchport access vlan 21
 switchport mode access
 channel-group 1 mode active
end
!
interface FastEthernet0/8
 switchport access vlan 21
 switchport mode access
 channel-group 1 mode active
end
!


Switch#sh etherchannel summary 

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa0/5(w)    Fa0/6(I)    Fa0/7(w)    
                                 Fa0/8(w)    
  • So far, switch config seems to be OK. Did you also set bondig mode / ether-channel settings / LACP settings in the drivers settings page on the server? – Sebastian Feb 17 '15 at 10:56
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer. – Ron Maupin Aug 11 '17 at 4:23
2

In addition to the port config mentioned below.....

At the end - you have several of the links status as:

 w - waiting to be aggregated

 i - inoperable

What does the Dell side config look like for those ports?

Are you using LLDP for on your switch and server? If so - what does the following output display from the Cisco side:

   sho lldp neighbor int fa0/5 
   sho lldp neighbor int fa0/6

You are using LACP for the Port-channel - that's the 'non Cisco proprietary one' so you're good there, and using adding that channel-group 1 mode active will force a trunk. Just make sure the Dell side is using LACP as well (I'm not sure what it tries by default). For reference:

  • You enable LACP on each channel by configuring the interface in that channel for the channel mode as either active or passive. When an LACP attempts to negotiate with an interface in the on state, it does not receive any LACP packets and becomes an individual link with that interface; it does not join the LACP channel group

You can also use the following command (on the Cisco side) to verify what Port-Channel Health:

 show int po1 brief
 show int po1 sw
 show int po1 trunk
1

As I stated in my comment already, DELL servers have Intel or Broadcom NICs built in (mostly and afaik).

You have to install the full driver and a special tool delivered with this driver (Intel) or a own configuration application (Broadcom, for example Broadcom Advanced Control Suite) to use LACP or other Link aggregation features with Windows. If you use Linux on the Server, you can create a bonding interface to use LACP support within the Linux kernel.

Additionally, use the information provided in the answer provided by Jonathan to check the health of your port channel while setting up the server-side.

I hope this helps.

Best, Sebastian

0
no switchport mode access vlan 21
switchport mode trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk vlan allowed 21
    channel-group 1 mode active

Turn the switch ports into a trunk. I've not seen any configuration in production that uses access ports for channel-groups. It may be that your configuration isn't necessarily wrong but that bonded NICs (trunked) should be configured trunk on both ends.

  • While a tagged link is more likely in most situations, I have come across a number of situations where this isn't the case. As such this may not apply to the OP question and create additional problems. – YLearn Feb 17 '15 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.