2

I am trying to configure link aggregation (LACP) from a server to a HP 2920-48G switch. The server has a 4 port Intel NIC that supports LACP, and a OS that natively supports LACP as well.

The switch has three modes for LACP, Passive, Active, and a separate "LACP Trunk" which appears to be primarily a proprietary option for trunking HP switches together. I have tried all three options on the two ports I am attempting to aggregate with no success. I have also read that I must have GVRP enabled on the ports, then forbid those ports from joining the default VLAN (as I am attempting to aggregate on a different VLAN then the default) to get dynamic LACP working. I have tried that with all three previous options and I still cannot get a working connection.

Any ideas on where I am failing?

2

Sounds like you're almost there.

You'll need to create a "team" on the server using two or more of the Intel ports. Use the Configure option in the NIC settings to choose 802.3ad.

Let's say you're using a team with two server NIC ports into two ports (47 and 48) on the same switch.

On the HP switch,

HP Procurve 2920> config
HP Procurve 2920(config)# int 47-48 lacp active
HP Procurve 2920(config)# show lacp

Check to be sure lacp status is "success"

Now patch in your server, each Intel NIC port to an HP port. Come back to the CLI and

HP Procurve 2920(config)# show lacp

to check if it's successful. Look for LACP partner = yes on both interfaces 47 and 48 and be sure all interfaces in your team are "up" Check your server to be sure traffic is flowing through both NIC ports. If so,

HP Procurve 2920(config)# write mem

to save configuration to memory.

6
  • The NICs are teamed in LACP on the server side of things. I will look into trying the rest of that though and get back to you with the results. – Litzner Feb 17 '15 at 15:17
  • To clarify, I should leave the interfaces disabled? – Litzner Feb 17 '15 at 15:33
  • No, you don't have to do that. I edited my post. Just a step I have always done but it appears to be unnecessary. – Ted Quanstrom Feb 17 '15 at 17:37
  • Well I think I have everything setup correctly when it comes to LACP, but I still am unable to communicate to that interface via IP. I am thinking the problem is somewhere with the VLANing or possibly on the server itself. tinypic.com/r/1zfo7sg/8 – Litzner Feb 17 '15 at 18:37
  • Ah, you are showing two seperate trunk groups. Try going into the Procurve's menu and create a new trunk group on those two ports. Trk1 or whatever is unused by something else. Then enable lacp active on the two ports. Then you should be showing the same "Trk1" or "Trk2" group when you run show lacp. – Ted Quanstrom Feb 17 '15 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.