1

I have a 25m CAT 5e cable and I'm trying to connect to a router. The connection obtained is always 100Base-TX full-duplex, it never reaches 1000Base-T. What can be the problem? As long as it says it's full duplex I assume the jacks are ok.

  • What devices are connected? are both ends capable of supporting 1g connections? – David Feb 18 '15 at 21:01
  • 2
    Are you sure all 8 conductors are connected straight through? 1 Gb requires all 8 conductors to work, and only having 4 conductors properly wired causes a 100 Mb connection. – Ron Maupin Feb 18 '15 at 21:01
  • Both devices are capable of Gigabit connections. If it says full-duplex doesn't it mean that it uses all the cables? – Razvan Feb 18 '15 at 21:11
  • 2
    @Razvan, full or half duplex for ethernet is not affected by the number of conductors in a cable. 100 Mb ethernet (disregarding PoE for the moment) uses two pairs (1-2,3-6) for either duplex. 1 Gb ethernet requires all 4 pairs of conductors. – Ron Maupin Feb 18 '15 at 21:27
  • 1
    @Razvan, I have little faith, based on your comment about not even knowing the pin layout, that you can actually terminate the horizontal cable correctly so that it can pass the required Category 5e tests. You may get it to work, but will it be reliable? Do you have the proper test equipment? If this is a critical application, it is well worth the time and money to get a professional to do it and provide a proper test report at the end. I have seen many people that make their own patch cords, but they won't pass the necessary tests, and they have intermittent problems that they just can't fix. – Ron Maupin Feb 18 '15 at 22:17
4

Ron hit the nail on the head for the most likely cause. As long as the router has a gig interface and the computer or switch connected to it is capable of gig speeds, then it's most likely a cabling issue. I had this same issue when I did some home wiring a few months ago, turned out 7 of the 8 wires were connected, not 8/8 = not 1000BaseT.

  • 1
    It has been a cable issue. I've redone the wiring and it works now. – Razvan Feb 19 '15 at 20:19
-1

Did you try to manually enter the speed, instead of auto-negotiation?

Try this under the switchport:

Switch(config-if)#speed 1000
Switch(config-if)#duplex full

On the host, if it is a Windows machine, right-click the adapter, click properties, then 'Configure' and then 'Advanced'. Click on 'Link Speed & Duplex' and under Value, choose 1.0 Gbps Full Duplex'

  • 3
    Per the standard, Gigabit Ethernet requires that the end points negotiate. You should never use speed 1000 on a switch port, rather to get the same result you should use speed auto 1000 to leave negotiation in place, but only allow Gigabit speeds. – YLearn Feb 18 '15 at 22:50
  • Yes, the specs requires negotiation, but the host ends can still be configured for specific settings -- the link will fail if they cannot be met. (Also, I see you've not used any AT&T gig metro-e circuits; it won't link if the CPE is looking for clause 73? info -- Earthlink tends to break my link once/twice a year when some busybody engineer sees "no neg" and turns it back on.) – Ricky Beam Feb 19 '15 at 5:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.