2

I'm trying to get DHCP relay set up on our Cisco SGE2010P switch. Sadly, we can't afford a catalyst switch right now. It looks like I have everything configured correctly, but something is going wrong. VLAN 5 is set up for DHCP relay with giaddr 10.0.10.9, DHCP server is at 10.0.3.4. I can see the DHCP Discover packet being sent by the host AND received by the server. The server replies with a DHCP Offer packet, but this is apparently dropped by the switch, because it never makes it back to the host.

The switch automatically creates static routes for VLAN interfaces (which are used as the giaddr IP). For this vlan the route is 10.0.10.0\23 and there is no nexthop address.

Let me know anything else you need to help troubleshoot this and I'll try to provide. Thanks!

2
  • 1
    Please share your config / topology. Is VLAN 5 the only VLAN with clients that need DHCP? Jun 22, 2015 at 11:50
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 11, 2017 at 4:38

2 Answers 2

2

You can check if DHCP snooping is enabled, you can try disable DHCP snooping or add your uplink port to trusted DHCP source.

3
  • Thanks, but DHCP snooping is disabled. Feb 23, 2015 at 14:35
  • I don't have a SGE2010P to test but it would sound strange if it drops DHCP response. Did you do some packet capture on the PC to see if it got any response back? If port mirroring is available you can try to do some packet capture on the switch interfaces too
    – theccie
    Mar 9, 2015 at 4:50
  • It's definitely a routing issue. Traceroute to 10.0.10.9 from the DHCP server shows the gateway as the second hop, and of course the gateway doesn't know that it's on link. Do I need a router to make this work? Mar 10, 2015 at 12:32
2

One post I ran across indicated they had to configure each VLAN as a DHCP relay and this resolved the issue:

Cisco SGE2010p, multi vlan, dhcp problem.

Michael9006 Feb 2, 2012 at 6:40 AM

I finally figured it out. I need to set up each VLAN as a DHCP relay. Just an FYI in case anyone else runs into this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.