3

I'm a bit out of my depth with this one & am terrified of making any mistakes.

We have two Cisco routers, R1 & R2, configured with BGP. They both have their own internet connections, however R1 is the main (larger) connection.

Problem is, R1 is routing out through R2 instead of its own internet connection.

router01#show bgp sum BGP router identifier 222.222.222.58, local AS
number 333333 BGP table version is 250008, main routing table version
250008 5 network entries using 740 bytes of memory 9 path entries
using 576 bytes of memory 3/2 BGP path/bestpath attribute entries
using 408 bytes of memory 1 BGP AS-PATH entries using 24 bytes of
memory 0 BGP route-map cache entries using 0 bytes of memory 0 BGP
filter-list cache entries using 0 bytes of memory BGP using 1748 total
bytes of memory Dampening enabled. 0 history paths, 0 dampened paths
BGP activity 125006/125001 prefixes, 125010/125001 paths, scan
interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ
Up/Down  State/PfxRcd
111.111.203.253 4       333333    1440    1444   250008    0    0 21:43:39        5
222.222.222.57  4         9822       0       0        1    0    0 21:43:31 Idle (PfxCt)

I'm stumped and out of my depth. 0.0.0.0 should be routing out through its interface 222.222.222.58 -> 222.222.222.57, but it's selecting 111.111.203.243 (R2)

Can you please help me get my head around why? The config looks fine to me. But again, out of my depth.

Here is the relevant config:

interface GigabitEthernet0/1
 description Primary Router Internet Link 20Mbit
 ip address 222.222.222.58 255.255.255.252
 duplex auto
 speed auto
!
router bgp 333333
 bgp log-neighbor-changes
 bgp dampening
 network 111.111.200.0 mask 255.255.255.0
 network 111.111.201.0 mask 255.255.255.0
 network 111.111.202.0 mask 255.255.255.0
 network 111.111.203.0 mask 255.255.255.0
 neighbor 111.111.203.253 remote-as 333333
 neighbor 111.111.203.253 next-hop-self
 neighbor 222.222.222.57 remote-as 9999
 neighbor 222.222.222.57 version 4
 neighbor 222.222.222.57 prefix-list announce out
 neighbor 222.222.222.57 maximum-prefix 125000
 neighbor 222.222.222.57 filter-list 1 in
!
ip forward-protocol nd
!
ip as-path access-list 1 deny _7473_
ip as-path access-list 1 deny _4648_
ip as-path access-list 1 deny _4637_
ip as-path access-list 1 deny _1239_
ip as-path access-list 1 deny _2914_
ip as-path access-list 1 permit .*
!
ip route 111.111.200.0 255.255.255.0 111.111.203.1
ip route 111.111.201.0 255.255.255.0 111.111.203.1
ip route 111.111.202.0 255.255.255.0 111.111.203.1
!
ip access-list extended isp-in
 remark DENY FRAGMENTS
 deny   tcp any any fragments
 deny   udp any any fragments
 deny   icmp any any fragments
 deny   ip any any fragments
 remark DENY IP OPTIONS
 deny   ip any any option any-options
 remark BGP SESSION
 permit tcp host 222.222.222.57 host 222.222.222.58 eq bgp
 permit tcp host 222.222.222.57 eq bgp host 222.222.222.58
 deny   ip any host 111.111.204.254
 deny   ip any host 111.111.204.253
 deny   ip any host 111.111.204.252
 deny   ip any host 222.222.222.58
 remark DEFAULT ALLOW
 permit ip any any
!
!
ip prefix-list announce description ALLOWED ROUTING ANNOUNCEMENTS
ip prefix-list announce seq 10 permit 111.111.200.0/24
ip prefix-list announce seq 20 permit 111.111.201.0/24
ip prefix-list announce seq 30 permit 111.111.202.0/24
ip prefix-list announce seq 40 permit 111.111.203.0/24
ip prefix-list announce seq 50 deny 0.0.0.0/0 le 32
5

Well, this node BGP session to ISP is down so you don't get any routes over 222.222.222.57 and that's why all the traffic goes to the other BGP neighbor:

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
111.111.203.253 4       333333    1440    1444   250008    0    0 21:43:39        5
222.222.222.57  4         9822       0       0        1    0    0 21:43:31 Idle (PfxCt)

The 'Idle (PfxCt)' status means this specific session exceeded maxium-prefix set and was reset. In your configuration you have 'neighbor 222.222.222.57 maximum-prefix 125000' which means the session was up for some time, then it exceeded 125k of prefixes and was reset.

Fix the limit and then we can check if the flow is correct from your point of view, once both sessions are up.

1
  • Thank you, for some reason our ISP has obviously made some changes on their end, as this was working until recently. – NeonMonk Feb 24 '15 at 9:55
0

Have you considered requesting a default route only from the ISP? This way you do not have to worry with the hardware limitations of receiving large routing tables.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.