2

I have a cisco switch 2960S with 2 vlans 2001 and 2002. On vlan 2001 runs a DHCP server (Windows Server 2012 R2) with ip 10.0.100.10 and a scope for vlan 2001 (10.0.100.50-99/24) and 2002 (10.0.200.1-99/24). For testing I used the following configuration (simplyfied):


vlan 2001,2002
!
interface GigabitEthernet0/1
 description *** Client network ***
 switchport access vlan 2001
 switchport mode access
!
interface GigabitEthernet0/2
 description *** FEMTO indoor box ***
 switchport access vlan 2002
 switchport mode access
!
interface GigabitEthernet0/3
 description *** Uplink router ***
 switchport mode trunk
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface vlan 2001
 ip address 10.0.100.1 255.255.255.0
!
interface vlan 2002
 description *** DHCP relay ***
 no ip address
 ip helper-address 10.0.100.10
 no ip route-cache
!
ip default-gateway 10.0.100.254

Now I have a real strange situation, if I connect a notebook or pc to port 2 on the switch - I get an ip address from the DHCP server in range 10.0.200.1. That works like designed but if I connect the FEMTO indoor box to the same port on the switch I dont get any ip address. I reset the FEMTO indoor box like the supporter told me but I still unable to receive any DHCP information. When I mirror the port and capture the traffic I only see some dhcp discovers entries from the FEMTO indoor box but no request/offer/ack entries.

A few day ago all the FEMTO indoor boxes were running without any problems, after I configured a new vlan (2002) they did not receive any DHCP informations until now. But why can I receive from any other client an ip address except the FEMTO indoor box and why are there no replies from the DHCP server to the DHCP discovers from the FEMTO indoor box?

Has someone any idea why this happens?

kind regards, Maede

3
  • Which is the vendor of this Femto?
    – vladiz
    Mar 12 '15 at 18:55
  • Sunrise Communications AG
    – Maede
    Mar 13 '15 at 8:27
  • Did any answer help you? if so, you should accept the answer so that the question doesn't keep popping up forever, looking for an answer. Alternatively, you could provide and accept your own answer.
    – Ron Maupin
    Aug 10 '17 at 23:12
2

The 2960S is not a full layer-3 switch. (but it does play one on TV.) The issue is the lack of an IP on VLAN2002. The dhcp-relay agent will have no information to forward to the DHCP server about which network the client belongs.

2
  • 1
    Why does it works if I connect any other device such as a notebook or pc to this port?
    – Maede
    Mar 13 '15 at 8:25
  • There's a lot more going on than you are describing. Is the switch acting as a router? (ip routing enabled) Is 10.0.100.1 the gateway on vlan 2001? What's on G0/3? As this thing is a telco provided "black box", you'll have to work with them to figure out what magic it requires to operate correctly. (all I can tell is that it was made by NEC. Maybe.)
    – Ricky
    Mar 13 '15 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.