0

In My Cisco Router i configured the following OSPF interfaces:

   interface eth1/0
      description link to net0 10.19.0.0/24 area 0 
      ip address 10.19.0.1 255.255.255.0
      ip ospf authentication message-digest
      ip ospf message-digest-key 1 md5 appropriate-password
      ip ospf cost 5000

interface eth1/1
      description link to p2p2 10.19.1.192/30 area 1 
      ip address 10.19.1.193 255.255.255.252
      ip ospf authentication message-digest
      ip ospf message-digest-key 1 md5 appropriate-password
      ip ospf cost 5000

    interface eth1/2
      description link to net3 10.19.2.0/24 area 0 
      ip address 10.19.2.1 255.255.255.0
      ip helper-address 10.19.0.20
      ip ospf authentication message-digest
      ip ospf message-digest-key 1 md5 appropriate-password
      ip ospf cost 5000

Then i have added the following interfaces

interface eth1/3
  description link to newnet4 10.19.16.0/23 area 2
  ip address 10.19.16.1 255.255.254.0
      ip helper-address 10.19.0.20
  ip ospf authentication message-digest
      ip ospf message-digest-key 1 md5 appropriate-password
  ip ospf cost 5000

interface eth1/4
  description link to newnet5 10.19.18.0/23 area 2
  ip address 10.19.18.1 255.255.254.0
      ip helper-address 10.19.0.20
  ip ospf authentication message-digest
      ip ospf message-digest-key 1 md5 appropriate-password
  ip ospf cost 5000

i want to put eth1/3 and eth1/4 into area 2 and aggregate area 2's announcement to the core to only advertise an appropriate /22 for the two interfaces.

I Have configured it as follow, but i coulden't get the expected behavior:

router ospf 1
    router-id 10.19.1.193
    log-adjacency-changes 

    network 10.19.1.0  0.0.0.255 area 0
    network 10.19.1.192  0.0.0.3  area 1
    network 10.19.2.0  0.0.0.255  area 0

    network 10.19.16.0  0.0.1.255 area 2
    network 10.19.18.0  0.0.1.255 area 2

    area 2   range 10.19.16.0  0.0.3.255

Could anyone please tell me what is wrong with my config ??

3

Could anyone please tell me what is wrong with my config

Simple. You used wildcards instead of netmasks. Also, you didn't enable authentication in the routing process.

[Cisco Reference: OSPF Design Guide]

| improve this answer | |
  • thank you but could you please be more specific and write me the correct config so i can understand it right ? – Snake Hernandez Mar 14 '15 at 3:31
  • 0.0.0.255 is a wildcard. 255.255.255.0 is a netmask. Given the tech with which you are now playing, you should know the difference. – Ricky Beam Mar 14 '15 at 3:35
  • i know but, i want to know where is the error, as far as i understood it's in the area command – Snake Hernandez Mar 14 '15 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.