6

I am trying to terminate an L2VPN on an MX480 but it's not working...

Topology: 7206 trunk vlanid 555 > MX80> MPLS CLOUD > MX480.

7206 (192.168.254.2) not pinging lt-interface on MX480 (192.168.254.1)

MX480 config:

PE_MX80> show configuration routing-instances
L2VPN_LT {
    instance-type l2vpn;
    interface ge-1/0/9.555;
    route-distinguisher 172.16.16.7:555;
    vrf-target target:65000:555;
    protocols {
        l2vpn {
            encapsulation-type ethernet-vlan;
            interface ge-1/0/9.555;
            site TEST {
                site-identifier 101;
                interface ge-1/0/9.555 {
                    remote-site-id 100;
                }
            }
        }
    }
}


PE_MX80> show configuration interfaces ge-1/0/9.555
encapsulation vlan-ccc;
vlan-id 555;

PE_MX80>


PE_MX80> show l2vpn connections instance L2VPN_LT
Layer-2 VPN connections:

Legend for connection status (St)
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down
LD -- local site signaled down   CF -- call admission control failure
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch

Legend for interface status
Up -- operational
Dn -- down

Instance: L2VPN_LT
  Local site: TEST (101)
    connection-site           Type  St     Time last up          # Up trans
    100                       rmt   Up     Mar 25 16:38:52 2014           1
      Remote PE: 172.16.16.2, Negotiated control-word: Yes (Null)
      Incoming label: 800007, Outgoing label: 800022
      Local interface: ge-1/0/9.555, Status: Up, Encapsulation: VLAN

PE_MX80>









P_480> show configuration routing-instances L2VPN_LT 
instance-type l2vpn;
interface lt-1/1/0.1;
route-distinguisher 172.16.16.2:555;
vrf-target target:65000:555;
protocols {
    l2vpn {
        encapsulation-type ethernet-vlan;
        interface lt-1/1/0.1;
        site TEST {
            site-identifier 100;
            interface lt-1/1/0.1 {
                remote-site-id 101;
            }
        }
    }
}

P_480> show configuration interfaces lt-1/1/0 
unit 1 {
    encapsulation vlan-ccc;
    vlan-id 555;
    peer-unit 2;
    family ccc;
}
unit 2 {
    encapsulation vlan;
    vlan-id 555;
    peer-unit 1;
    family inet {
        address 192.168.254.1/30;
    }
}


P_480> show configuration chassis 
aggregated-devices {
    ethernet {
        device-count 5;
    }
}
fpc 1 {
    pic 1 {
        tunnel-services;
    }
    sampling-instance IPFIX_TEST;
}
network-services enhanced-ip;

P_480> 
P_480> show l2vpn connections instance L2VPN_LT 
Layer-2 VPN connections:

Legend for connection status (St)   
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present 
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down                      
LD -- local site signaled down   CF -- call admission control failure      
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch

Legend for interface status 
Up -- operational           
Dn -- down

Instance: L2VPN_LT
  Local site: TEST (100)
    connection-site           Type  St     Time last up          # Up trans
    101                       rmt   Up     Mar 25 16:39:24 2015           1
      Remote PE: 172.16.16.7, Negotiated control-word: Yes (Null)
      Incoming label: 800022, Outgoing label: 800007
      Local interface: lt-1/1/0.1, Status: Up, Encapsulation: VLAN

P_480>

add info INF and BGP

MX80_PE> show configuration protocols bgp
group MPLS-VPN {
    type internal;
    family inet {
        unicast;
    }
    family inet-vpn {
        unicast;
    }
    family l2vpn {
        signaling;
    }
    neighbor 172.16.16.6 {
        local-address 172.16.16.7;
        export NHS;
    }
    neighbor 172.16.16.2 {
        local-address 172.16.16.7;
        export NHS;
    }
}




MX480> show configuration protocols bgp group MPLS-VPN 
type internal;
local-address 172.16.16.2;
family inet {
    unicast {
        rib-group AGGREGATE_TO_NAT_TABLE;
    }
    multicast;
}
family inet-vpn {
    unicast;
}
family l2vpn {
    signaling;
}
......................
neighbor 172.16.16.7 {
    description MX80_Mitishi;
    export EXPORT_TO_PE;
}


MX480> 


interface:

MX480> show configuration interfaces lt-1/1/0 
unit 1 {
    encapsulation vlan-ccc;
    vlan-id 555;
    peer-unit 2;
    family ccc;
}
unit 2 {
    encapsulation vlan;
    vlan-id 555;
    peer-unit 1;
    family inet {
        address 192.168.254.1/30;
    }
}

=============================

7206 interface facing to MX80

interface GigabitEthernet0/1.555
 description test l2vpn
 encapsulation dot1Q 555
 ip address 192.168.254.2 255.255.255.252
 ip flow ingress
 ip flow egress

!
  • Can you please share your BGP configuration for the corresponding neighbor, and the configuration for the interfaces in the l2vpn (on both devices) – Jordan Head Mar 26 '15 at 5:07
  • i add info about BGP and Interface – Артём Лисенков Mar 26 '15 at 9:34
  • Have you checked re filters on MX480 are not blocking ICMP? Do you have ARP entries on the boxes for the IPs? – Sebastian Wiesinger Mar 26 '15 at 12:59
  • ICMP not blocked. RE filter blocks only SNMP, SSH... – Артём Лисенков Mar 26 '15 at 14:16
2

Pretty sure you need to add family ccc to the interface on the PE_MX80.

set interfaces ge-1/0/9 unit 555 family ccc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.