2

This is my Cisco ASA 5505 "show run":

: Saved
:
ASA Version 8.2(5) 
!
hostname LAB-ASA
domain-name TEST.com
enable password X encrypted
passwd X encrypted
names
name 192.168.1.0 AsusWireless
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 172.16.1.1 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xx.xx.xx.xx 255.255.255.248 
!
ftp mode passive
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 domain-name TEST.com
object-group protocol DM_INLINE_PROTOCOL_1
 protocol-object ip
 protocol-object udp
 protocol-object tcp
object-group protocol DM_INLINE_PROTOCOL_2
 protocol-object ip
 protocol-object udp
 protocol-object tcp
object-group protocol DM_INLINE_PROTOCOL_3
 protocol-object ip
 protocol-object udp
 protocol-object tcp
object-group protocol DM_INLINE_PROTOCOL_4
 protocol-object ip
 protocol-object udp
 protocol-object tcp
access-list TUNNEL_LIST standard permit 172.16.1.0 255.255.255.0 
access-list TUNNEL_LIST standard permit 172.16.16.0 255.255.255.0 
access-list outside_in extended permit icmp any host xx.xx.xx.xx 
access-list outside_in extended permit ip 172.16.16.0 255.255.255.0 any 
access-list outside_in extended permit ip 172.16.1.0 255.255.255.0 any 
access-list inside_in extended permit icmp any any log 
access-list inside_in extended permit tcp any any log 
access-list inside_in extended permit udp any any log 
access-list inside_in extended permit ip any any log 
access-list inside_in extended permit ip 172.16.16.0 255.255.255.0 any 
access-list inside_in extended permit ip 172.16.1.0 255.255.255.0 any 
access-list inside_in extended permit object-group DM_INLINE_PROTOCOL_1 interface inside any 
access-list inside_in extended permit object-group DM_INLINE_PROTOCOL_3 AsusWireless 255.255.255.0 any 
access-list inside_out extended permit icmp any any log 
access-list inside_out extended permit tcp any any log 
access-list inside_out extended permit udp any any log 
access-list inside_out extended permit ip any any log 
access-list inside_out extended permit object-group DM_INLINE_PROTOCOL_2 172.16.1.0 255.255.255.0 any 
access-list inside_out extended permit object-group DM_INLINE_PROTOCOL_4 AsusWireless 255.255.255.0 any 
access-list outside_out extended permit icmp any any log 
access-list outside_out extended permit tcp any any log 
access-list outside_out extended permit udp any any log 
access-list outside_out extended permit ip any any log 
pager lines 24
logging console debugging
mtu inside 1500
mtu outside 1500
ip local pool VPN_CLIENTS 172.16.16.16-172.16.16.64 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 172.16.1.0 255.255.255.0 outside
nat (inside) 0 AsusWireless 255.255.255.0 outside
access-group inside_in in interface inside
access-group inside_out out interface inside
access-group outside_in in interface outside
access-group outside_out out interface outside
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.xx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
 description "AnyConnectACL"
 network-acl inside_in
 network-acl inside_out
aaa authentication ssh console LOCAL 
aaa authentication telnet console LOCAL 
http server enable
http 172.16.1.0 255.255.255.0 inside
http AsusWireless 255.255.255.255 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map inside_map interface inside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication crack
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 20
 authentication rsa-sig
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption aes-256
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 40
 authentication crack
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 50
 authentication rsa-sig
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 60
 authentication pre-share
 encryption aes-192
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 70
 authentication crack
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 80
 authentication rsa-sig
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 90
 authentication pre-share
 encryption aes
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 100
 authentication crack
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 110
 authentication rsa-sig
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 120
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 130
 authentication crack
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 140
 authentication rsa-sig
 encryption des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 150
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh 172.16.1.0 255.255.255.0 inside
ssh AsusWireless 255.255.255.255 inside
ssh timeout 5
console timeout 0
management-access inside
dhcp-client update dns server both
dhcpd address 172.16.1.5-172.16.1.36 inside
dhcpd dns 8.8.8.8 8.8.4.4 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable inside
 enable outside
 anyconnect-essentials
 svc image disk0:/anyconnect-win-3.1.05187-k9.pkg 1
 svc image disk0:/anyconnect-linux-64-3.1.05187-k9.pkg 2
 svc image disk0:/anyconnect-linux-3.1.05187-k9.pkg 3
 svc image disk0:/anyconnect-macosx-i386-3.1.05187-k9.pkg 4
 svc enable
 tunnel-group-list enable
group-policy DfltGrpPolicy attributes
 dns-server value 172.16.1.2
 vpn-tunnel-protocol webvpn
 split-tunnel-network-list value TUNNEL_LIST
 split-tunnel-all-dns enable
 webvpn
  svc rekey method ssl
  svc compression deflate
group-policy GroupPolicy1 internal
group-policy GroupPolicy1 attributes
 wins-server none
 dns-server value 172.16.1.2 8.8.4.4
 vpn-filter value inside_in
 vpn-tunnel-protocol IPSec l2tp-ipsec svc 
 group-lock value AnyConnectProfile
 split-tunnel-policy tunnelall
 split-tunnel-network-list value TUNNEL_LIST
 default-domain value TEST.com

tunnel-group AnyConnectProfile type remote-access
tunnel-group AnyConnectProfile general-attributes
 address-pool VPN_CLIENTS
 authorization-server-group LOCAL
 default-group-policy GroupPolicy1
tunnel-group AnyConnectProfile webvpn-attributes
 group-alias AnyConnectProfile enable
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect ip-options 
  inspect netbios 
  inspect rsh 
  inspect rtsp 
  inspect skinny  
  inspect esmtp 
  inspect sqlnet 
  inspect sunrpc 
  inspect tftp 
  inspect sip  
  inspect xdmcp 
!
service-policy global_policy global
prompt hostname context 
no call-home reporting anonymous
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:e09e55d66228358f8038da3c81d19847
: end
asdm location AsusWireless 255.255.255.0 inside
no asdm history enable

I was playing with ASDM and now no one has internet in whole network, there is AsusWireless (wireless router) which assigns people with IP addresses such as 192.168.1.X, none of those and non of people connected directly to Cisco ASA (172.16.1.X) and none of people who connected through AnyConnect (172.16.16.X) does have internet. No internet at all. But when I go to ssh of Cisco router and when I ping Google servers, it's connected and does have internet. What's wrong? What did I do wrong?

  • First question: WHAT DID YOU CHANGE? (from the looks of it, your acl's are a complete mess.) – Ricky Beam Mar 31 '15 at 18:21
  • Looks like routing and NAT are ok so I agree with Ricky Beam on the access lists. If you're trying to block access outbound to anything specific or on a single protocol try removing that and leaving just the implicit outbound rule in place. – Todd Wilcox Mar 31 '15 at 18:39
  • You can use the packet tracer feature of ASDM to tell you exactly where you are blocking traffic. Also, as a side note, if you try to log everything with ACLs, you are going to have performance problems. – Ron Trunk Mar 31 '15 at 21:56
2

The problem is

nat (inside) 0 172.16.1.0 255.255.255.0 outside
nat (inside) 0 AsusWireless 255.255.255.0 outside

"nat 0" tells the firewall not to do translation. you should say "nat 1" to associate the nat with the

global (outside) 1 interface

command.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.