1

MY QUESTIONS ARE:

  1. What could be the cause of this nondeterministic HP switch behaviour ?!
  2. Why sometimes devices make 100Mb link and sometimes 1Gb ?!

HP 1810-24G and Mikrotik CloudCore1036 - 1Gb link negotiation problem between

At above picture You can see part of my network scheme. Main router based on Mikrotik CloudCore1036 within one bridge and HP 1810-24G switches within default VLAN.

I tried to make bonding between them using 802.3ad protocol because I know that my HP support this old one and I didn't have time to make additional experimental configuration (balanced-rr doesn't work because makes huge issue with ARP broadcasting along the whole network !!!). I noticed that bonding didn`t work properly because of links speeds between devices:

  • CC1036 announce to the HP all full-duplex link speeds like 10/100/1000,
  • HP announce only full-duplex 10/100 at E23 but at E24 also 1000 for example.

What is more strange sometimes HP gives to the LAN hosts 100Mb speed and sometimes 1Gb speed at the same ports - hosts always have 1Gb NICs. All HP ports are at admin mode and they have Autonegotiation enabled - CC1036 also. I cheked whole wiring between CC1036 and HP and all strands are ok. Top cable lenght is about 11m Cat5E.

  • Can you post the output you're seeing? – Ryan Foley Jun 10 '15 at 15:12
  • Hardcode the ports on the HP to 1Gig Leave the CPE/CloudCore on autonegotiate? – Ron Royston Jun 10 '15 at 22:58
  • As a sidenote/anecdote, I don't understand why Mikrotik has such a hard time dealing with autonegotiation. When I first checked Mikrotik out over 5 years ago they had problems with it and to this date this still do. Search the internet for "mikrotik autonegotiate" and you'll notice straight away lots of people have issues it with. Some 2 years ago I had to uplink a Cisco 1921 to a Mikrotik and the Cisco side kept negotiating to 1 gbps half duplex while the Mikrotik was running full duplex. Both sides were set to "auto". Replacing cables didn't help, in the end the Mikrotik was replaced. – RedShift Jul 10 '15 at 19:46
  • Question, is all the equipment properly grounded? – RedShift Jul 10 '15 at 20:34
  • Wow oO I didn't suspect such thing like this. I know that CC is using 3 wires electrical network and HP switch is ungrounded because eletrical line is using 2 wires. – user3799089 Jul 19 '15 at 11:07
0

[ this solution is for Mikrotik part of your setup, but the principle is the same of any decent equipment ]

You can specify what capabilities your Mikrotik device will present to the other side (HP switch in your case). If you go (in Winbox) to Interfaces->Ethernet and select the port you are interested in, you can specify under Ethernet tab whether you allow auto negotiation and what do you advertise. In case of such issues I usually keep autonegotiation and specify only highest speed available on both sides - in your case you would specify only "1000M full" - being 1000Mbps with full duplex. This way HP will have only one option to negotiate on.

You can, of course, also set things statically, but limited auto-negotiation always worked good in my experience.

  • So what is the different between static 1000Mb Full Duplex and negotiation with same speed ? :] Effect wouldn't be the same ? If something goes wrong connection wouldn't be established. – user3799089 Apr 13 '15 at 7:48
  • With advertising speed and duplex the other side does not need to guess proper settings so less space for error. Auto negotiation on one side and limited advertised options means less trouble for both sides. – Tomaž Jul 20 '15 at 19:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.